Dynamic Forms creation

Topics: Installing Orchard, Troubleshooting
Oct 4, 2015 at 4:38 PM
Edited Oct 4, 2015 at 4:52 PM
How do I create a dynamic form?

I looked at the following directions: http://docs.orchardproject.net/Documentation/Creating-Dynamic-Forms and when I enable the Dynamic Forms Module I do not see a new content type in the list.

I downloaded a brand new copy of Orchard 1.9.1 this morning and did a vanilla install with SQL CE and no other changes.

I should add that I created a new Web Site in IIS, gave IIS_USRS full permissions, changed App Pool to ASP.NET 4.0/Integrated.

--- Update but how do I fix on other installs?

If I install using Web Platform Installer (with Web Matrix 3) I can enable the Dynamic Forms Module and it works!
Oct 5, 2015 at 1:47 PM
When you enable Dynamic Forms the first time, it should create a new Form content type. If that did not happen, can you please try on a clean install (go through Setup) and try again? Alternatively, when creating a new Page, can you confirm that you see the Form element in the Forms category of the Layouts toolbox?
Oct 6, 2015 at 12:25 AM
When I enable the module I do not see a Form option in the new content area.

I tried a clean install doing the following:
  1. Download Zip file from orchardproject.net
  2. Create website in IIS
  3. Setup IIS permissions
  4. Setup app using SQLCE as DB
Same problems still exist


If I download and install using Web Platform Installer and fire up WebMatrix 3 then everything works!

I also noticed that if I use the first method then the image editor module doesnt work either.

Oct 7, 2015 at 1:19 PM
I also had this with a clean installation of 1.9.1, still don't know what could be the issue
Oct 8, 2015 at 11:28 AM
Edited Oct 8, 2015 at 11:29 AM
Here is what I did to solve the issue:
  1. Download the source
  2. Compile source
  3. Publish source to a new directory
  4. copy over the following directories form publish to my orchard installation:
  5. bin
  6. Config
  7. Core
  8. Modules
Now everything works and even the Image editor now works too!

Does that explain anything?
Oct 9, 2015 at 1:17 PM
Seems there is something wrong with the precompiled release zip (Orchard.Web.1.9.1.zip) where the Dynamic Forms aren't working on deployment