This project is read-only.

Contact Form - Specify a custom message when the form is submitted

Topics: Administration
May 7, 2015 at 1:57 AM
Edited May 30, 2015 at 1:22 AM
Hi, I'm new to Orchard.
I created a Contact Form with a custom message for when the form is submitted on an azure hosted site - the form submitted message only works correctly in Internet Explorer. In other browsers the form submitted message only shows when I navigate to another page. Has anyone ever had this issue? Thanks.
May 7, 2015 at 9:59 AM
What feature did you use to create your contact form? Custom Forms, Dynamic Forms, or something else?
May 7, 2015 at 3:52 PM
Edited May 7, 2015 at 4:17 PM
I used the Custom Forms module, created a Contact Form content type, then created a Contact Form. I've since added a redirect page and enabled RedirectUrl in the form and the message shows in Firefox and Chrome (I guess this is workable), but without the redirect page, the message only shows in IE.
May 30, 2015 at 1:13 AM
Edited May 30, 2015 at 1:20 AM
Form submission and submission message:

The above work around didn't really work. I discovered that - although the page would be redirected to another page, the comments wouldn't be listed in the comments section in the dashboard.

What has worked for me is upgrading to the 1.9 version of Orchard, but this only worked when I deleted the existing Azure web app and created it again.

What I did:
Following the instructions from (
I downloaded my 1.8 site (sftp) and did the upgrade local as per the instructions (there were some issues that I ironed out but, that'll have to be another post),and then published using web matrix. When I did this the comments form wouldn't submit in Firefox. So I then wiped the Azure app, created it again, and published on a clean newly created Azure web app, selecting the option to delete files on the server that are not local. Now both the contact form and the comments form now submit in both Chrome and Firefox and the submission messages are displayed.

If I have to do this again, I may try delete the folder via sftp, so I don't have to re-created the web app and custom domain settings.

Just wanted to post, in case anyone else has a similar issue.
Marked as answer by William100 on 5/29/2015 at 5:21 PM