This project is read-only.

Admin dashboard - most of the pages are not loading at all.

Topics: Administration, Core
Apr 27, 2015 at 10:38 AM
Edited Apr 27, 2015 at 2:49 PM

I've been having some problems with one of my orchard project on the hosting server.
After install, publish etc, all worked fine. Then tried to install one of the widgets from gallery, and started seeing "missing reference" message after login to the admin panel - but, all worked fine anyways (message there, but didn't cause me any problems ... until now - i mean i don't know if it's related ).
The problem I'm experiencing now, is to do with admin pages. Apart from few, any page I click on in the Dashboard menu is blank - please see attached picture.

And as I said earlier, it worked fine on the hosting server, then one day it just stopped - maybe it is hosting related.
Funny fact is, that I can access all admin pages if I run the project locally - visual studio 2013 ( still connecting to the hosting server database thou).

Any help would be appreciated :)

Edit: list of working pages:
New Page, New Projection, Content(screenshot above), Content Definition, Modules (but Installed tab is blank).
Rest of the pages are blank (as per screenshots above).

Apr 27, 2015 at 12:39 PM
Looks like the module you installed was written for an older version of Orchard using ClaySharp, which was removed at some point.
Apr 27, 2015 at 1:01 PM
Edited Apr 27, 2015 at 1:04 PM
Hi sfmskywalker,

Yes, I read about it and that's exactly what it is, however I don't believe that is the cause of my issue.
As I mentioned, it worked fine with this "ClaySharp" error message, but then at one point it just stopped showing other pages.

I followed instructions online, to get rid of the "ClaySharp" error, but it didn't fix my problem ... Then I restored it and here it is again :)
And again, vs2013, localhost can connect to the database hosted externally and it shows all the pages and data fine.

Also forgot to mention, it happened to me some time ago, but I just ignored the problem - after few logging ins and outs it started showing the pages again, but now cannot get it to work :/

edit: FireFox / firebug doesnt show any errors for those pages, nor javascript / html problems.
And also as you can see from the screenshots, Content page loads fine. There are few other pages that I can load, but rest is blank.
Apr 27, 2015 at 1:21 PM
Is there anything in your log files (App_Data/Logs) that may indicate the cause of the issue?
Apr 27, 2015 at 1:59 PM
Nothing in the logs (except for ClaySharp):
2015-04-27 10:17:00,389 [9] Orchard.Environment.DefaultAssemblyLoader - (null) - Error loading assembly 'ClaySharp'
.... and rest of the details, and another one from today:
2015-04-27 10:17:00,389 [9] Orchard.Environment.Extensions.Compilers.DefaultExtensionCompiler - (null) - Assembly reference 'ClaySharp' for project '/Modules/Orchard.DesignerTools/Orchard.DesignerTools.csproj' cannot be loaded

... and the details.

Nothing that can point me in the right direction.
I hoped to find some errors in logs / firebug / vs 2013 (debug) , but nothing is there.
Apr 27, 2015 at 2:46 PM
Quick update:

This is what gets inserted into the id="content" div for those blank pages.
<div id="content" class="group">
    <div class="zone zone-content">
        <!DOCTYPE html>
        <html lang="en">
                <meta charset="utf-8" />