AutoFac Conflict Resolution

Topics: Customizing Orchard
Apr 22, 2015 at 10:03 PM
Hi,
I am currently working on a project in Orchard. We are looking to wrap up an existing .NET MVC Web application within an Orchard Module. Currently, we are having issues with AutoFac.

The original site was built using AutoFac 3.5, however the latest stable version of Orchard is still running on 3.0. The application requires features introduced in 3.3. If I install 3.0 into the module, the features do not work, if I have 3.5 in the module, it produces a conflict.

Can anybody suggest a way of handling this conflict? Or, is it safe to upgrade AutoFac 3.0 in Orchard?

Thanks,
Coordinator
Apr 22, 2015 at 11:08 PM
1.x and in result 1.9-int contain Autofac 3.5.2. You can find the change on this commit: https://github.com/OrchardCMS/Orchard/commit/fe0c1a8a032b80faa04892838291d07685eb5f3e

It seems that it's just a matter of binaries, no code change, so this is safe to do. You can also use 1.9-int instead.