This project is read-only.

Workflow broken in 1.x?

Topics: Customizing Orchard, General
Nov 12, 2014 at 4:09 AM
Edited Nov 12, 2014 at 4:10 AM
I upgraded one of my projects to 1.x because I needed the dynamic forms. Worked very well so far. But when I try to set up a workflow with an user task or a decision (where the outcomes are generated dynamically) I can't see the outcome on the line and the line doesn't get saved.

I pulled the 1.x branch in a new folder and tried it - but same behavior.

Nov 14, 2014 at 5:02 PM
Edited Nov 14, 2014 at 5:07 PM
Sorry for pushing this, but can anybody either confirm or deny it? Because I tried it on a different development machine with a new 1.x source -> same problem.
Nov 15, 2014 at 4:03 AM
I can confirm, this is an issue. If you don't mind, please create an issue for this (including your nice screen snippet).
Marked as answer by benschi11 on 11/15/2014 at 9:17 AM
Nov 15, 2014 at 5:17 PM
Thanks for confirmation (I thought I was crazy :) ).

Issue is created:
Marked as answer by benschi11 on 11/15/2014 at 9:17 AM
Nov 15, 2014 at 9:50 PM
You're welcome. :)
Thanks for creating the issue.
Nov 15, 2014 at 10:06 PM
Hi! Do you know what is exactly the problem and how to fix it? (Because I need the workflow on 21.11. and otherwise I will try to rollback to 1.8)
Nov 16, 2014 at 9:41 AM
Edited Nov 16, 2014 at 10:35 AM
I started looking into it, and found that it was introduced with changeset 12d3eb66dca384ea559bbb35c72330759ab6cc07. I'll look into it.
Nov 16, 2014 at 10:31 AM
Marked as answer by benschi11 on 11/16/2014 at 10:25 AM
Nov 16, 2014 at 6:25 PM
Amazing. Thanks for your work. I will try it out today!