.Net Framework Version Error in Orchard

Topics: Core
Oct 3, 2014 at 6:03 PM
I keep getting this error with modules that I install from the gallery and don't understand what it means. I have the .Net Framework version 4.5 installed on my machine.

Warning 2 The primary reference "C:\inetpub\MyOrchard\src\Orchard\bin\Debug\Orchard.Framework.dll" could not be resolved because it was built against the ".NETFramework,Version=v4.5" framework. This is a higher version than the currently targeted framework ".NETFramework,Version=v4.0". Iroo.VersionManager
Oct 3, 2014 at 9:02 PM
I think that error causes a module thats target Framework 4 but references to Orchard.Framework.dll, which is build with 4.5. So you maybe need to retarget the module to the new framework version.
Oct 7, 2014 at 2:50 PM
Any ideas how to retarget a module?
Oct 7, 2014 at 6:03 PM
Edited Oct 7, 2014 at 6:07 PM
Go to Project Properties of your module, go to the Application tab, and change the target framework to 4.5.
Marked as answer by emeraldarcher on 10/7/2014 at 1:24 PM
Oct 7, 2014 at 8:24 PM
Thank you.