This project is read-only.

How to force dynamic compilation

Topics: Core, General, Troubleshooting, Writing modules, Writing themes
Jul 30, 2014 at 5:13 PM

Please, i really need help on this as fast as possible!

I am having trouble updating a live site... the .cs changes take too much time!!!

I don't know how to force IIS or Orchard to apply changes.. i make updates installing custom modules (nupk packages).

Thx a lot!
Aug 1, 2014 at 1:35 AM
So are you saying that dynamic compilation works, but it takes too much time?
Or are you saying that it doesn't work at all?
You can check ~/Config/HostComponents.config to see if dynamic compilation is disabled or enabled.
Aug 1, 2014 at 2:18 PM
Changes on the .cs are not working... Even after restarting the IIS, and making a recycle...
I mean: i make changes on a controller, for example i add a new method, then when i install the new module upgrading the last one it just does not work..
Aug 1, 2014 at 7:03 PM
Dynamic compilation should be disabled on production. It's enabled by default when you download the source version. What is recommended is that you compile the module on your dev machine. then copy the /bin/YOURMODULE.DLL file to your production, then restart the site.