Upgrade issue: from v1.7 to v1.8

Topics: Installing Orchard
Jul 2, 2014 at 12:38 PM
Edited Jul 3, 2014 at 5:35 AM

I tried to upgrade our project (which also consists custom modules) from Orchard 1.7 to 1.8 using the existing DB but I am facing stackoverflow exception in Autofac.dll. I am struggling to resolve this issue from past few weeks. However, I am able to upgrade to 1.8 by creating new database for Orchard.

Exception details: An unhandled exception of type 'System.StackOverflowException' occurred in Autofac.dll

I also tried to resolve this issue by upgrading to 1.7.1, next 1.7.2, next 1.7.3 and then 1.8 and I was successfully able to upgrade till 1.7.3 (using existing DB) but with 1.8 I am facing the same issue.

Is it possible to upgrade to 1.8 using the existing DB?

Appreciate your help. Thanks.
Jul 3, 2014 at 8:24 AM
Me, too, have the problem similar when upgrade from 1.7.2 to 1.8 or even 1.8.1 like I mention here https://orchard.codeplex.com/discussions/544121

Still no luck at all.
Jul 3, 2014 at 9:20 AM
Yes even when I try to upgrade to 1.8 without any of the custom modules using existing database, it doesn't work.
Jul 7, 2014 at 8:14 AM
It seem that 1.8.1 is working for me now. When first run (after build custom modules), it take some time to background migrating. After that the site could tun normally.

Thank Orchard Team.
Jul 7, 2014 at 8:38 AM
Hi, I tried 1.8.1 as well but still I am facing the same issue using existing database. Can you please provide the exact steps that you followed to make it work? That would be of great help. Thanks.
Jul 7, 2014 at 8:54 AM
Step 1:
Delete all modules that you don't need anymore.

Step 2:
Clean your App_Data (in my case, delete all except App_Data\Sites\Default\Settings.txt)

Step 3:
Replace Orchard (include bin, Config, Core, Orchard's default modules and themes) with new version 1.8.1

Step 4:
Follow this http://english.orchardproject.hu/blog/upgrading-your-module-to-be-orchard-1-8-compatible to upgrade your custom modules (include modules installed form Orchard Gallery).

Finally, run the site and be a little patience because of migrating need some time.
Jul 7, 2014 at 9:51 AM
Page cannot be displayed message is shown when I clicked on the below url.
Jul 7, 2014 at 10:48 AM
Jul 8, 2014 at 9:32 AM
Still no luck..Didn't work :(

Also gone throught the below posts and tried but didn't work..
  1. https://orchard.codeplex.com/workitem/19515
  2. https://orchard.codeplex.com/workitem/18718
Jul 8, 2014 at 10:38 AM
Hi Swati,

I just upgraded my Local Orchard v1.5.1 website to v1.8.1 no custom modules with existing database. It works.
Jul 8, 2014 at 10:46 AM

Thanks for your response.

I would like to know the following things for my understanding. Can you please help me with these queries?
  1. Do you have custom modules in your application?
  2. If yes, does your existing database contains data related to custom modules? (I think it will contain)
My existing DB contains data related to my custom modules. When I tried to use existing DB even without adding any custom modules in v1.8.1 solution, it was not working. However, it's working in v1.7