This project is read-only.

Running in debug mode of Orchard 1.8 web application shows Directory Listing

Topics: General, Troubleshooting
May 9, 2014 at 5:59 AM
When i run Orchard 1.8 Site in debug mode using VS 2012 Express. It shows directory browsing page. In VS 2012 Express i can see the symbols are loading. After loading all the symbols when i refresh the site on browser, it shows me the home page. Recently i migrate Orchard 1.3 to Orchard 1.8. I want to load the home page after loading all the symbols in VS 2012 express.

http://localhost:30320/OrchardLocal/ which is the same as it was before. The page title is:
Directory Listing -- /OrchardLocal/
with all the dirs/files listed below.

Please suggest.......
May 9, 2014 at 1:49 PM
clean , build , F5 again
May 9, 2014 at 2:51 PM
Clean, build does not solve the problem
May 9, 2014 at 4:05 PM
Read your log file.
May 9, 2014 at 4:06 PM
It could be that for some reason the site can't start. Take a look at the logs for a clue.
May 10, 2014 at 7:04 AM
After deleting the log file when i run the application. I can see log file created but with no log record.
May 10, 2014 at 12:57 PM
Is there no record even after you close the server? Log entries are not flushed immediately all the time.

Also, did you change anything in your Settings.txt file, or have you changed tenant settings through the Multi Tenancy module?
May 11, 2014 at 11:18 AM
I get this when the Database is not reachable, try incrementing the log level in the file config/log4net.config according the instructions.