Missing Web Components with v1.8

Topics: Installing Orchard, Troubleshooting
Apr 30, 2014 at 1:34 AM
I upgraded to version 1.8, seems to be working fine. The trouble I'm having is bringing up the source code in Visual Studio. Before the source codes loads it gives me an error:
The Web project 'Orchard.Core' requires missing web components to run with Visual Studio. Would you like to download and install them using the Web Platform Installer now?
(Note: Some components might require restart to take effect.)

ASP.NET Web pages with Razor syntax
Prior versions did not do this. If I select 'Yes' to install the missing components I get an error with the Web Installer that says it couldn't find the product you tried to install. When I exit out of that the solution loads just fine and doesn't seem to have any errors.

What do I need to do to stop this error from continuing?
Apr 30, 2014 at 3:23 AM
If you have installed complementary modules, do check that their references point to good assemblies from /lib and adapt their web.config to what is used in any orchard.xxxx module.
Last solution if previous nok, clone 1.8.x for your code.
Apr 30, 2014 at 6:12 PM
The problem is actually with all the modules, not any of mine or any add-on modules. If I say 'No' to installing the missing component it just moves on to the next module and gives me the same error. This repeats through all of the modules in the project.
Apr 30, 2014 at 8:51 PM
Edited May 1, 2014 at 2:44 AM
I don't understand what you are saying, sorry.
May be you don't give enough details.
Anyway I had no visual studio pbs with sources from a cloned 1.8.x.
May 1, 2014 at 2:23 AM
This is the window I see when I start the solution:


If I click 'No' it just moves on to the next module until it goes through all the modules that are in the source code. If I select 'Yes', then it takes me to the web platform installer which comes up with this screen:


I don't know what it is looking for and I'd really like to figure it out because I have to go through this every time I launch the solution in Visual Studio.
May 1, 2014 at 2:49 AM
Edited May 1, 2014 at 2:50 AM
Which vs version, OS and which solution file? How do you install the new source ? What do you mean when you say that the upgrade is ok without having the source code installed correctly ???
May 1, 2014 at 12:26 PM
Edited May 1, 2014 at 2:18 PM
I'm using VS 2012 on Win 7. The source is installed from a zip file, I don't know of any other installation than that.

I say it's okay because after I get through the errors I've show you everything works just like any prior versions.
Jun 10, 2014 at 8:58 AM

did you manage to find a resolution to this? I have exactly the same issue and am using the same versions of VS and Win 7.

Jun 12, 2014 at 12:09 AM
Yes I did. The problem is that VS 2012 is not setup to use MVC5, you need VS 2013 for that or you need to install the Web Tools 2013.1​ for MVC5 and Web API 2. I installed the web tools. Once I did that I was able to open v1.8 of Orchard again without any errors. You shouldn't have any nuget packages installed for Orchard either. If you have any custom modules you will need to update those to the latest versions of the binaries you have in your references.