Upgrading from 1.5.1 to anything is throwing me a ton of errors

Topics: Installing Orchard, Troubleshooting
Apr 18, 2014 at 7:28 PM
Edited Apr 18, 2014 at 7:53 PM
Hi All,
Here's the error that I'm getting.

Server Error in '/' Application.

The type 'Orchard.Localization.Services.CultureDateTimeFormatProvider, Orchard.Framework' could not be found. It may require assembly qualification, e.g. "MyType, MyAssembly". 
  Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

 Exception Details: System.Configuration.ConfigurationErrorsException: The type 'Orchard.Localization.Services.CultureDateTimeFormatProvider, Orchard.Framework' could not be found. It may require assembly qualification, e.g. "MyType, MyAssembly".

Source Error: 


 An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace: 



[ConfigurationErrorsException: The type 'Orchard.Localization.Services.CultureDateTimeFormatProvider, Orchard.Framework' could not be found. It may require assembly qualification, e.g. "MyType, MyAssembly".]
   Autofac.Configuration.ConfigurationSettingsReader.LoadType(String typeName, Assembly defaultAssembly) +292
   Autofac.Configuration.ConfigurationSettingsReader.Load(ContainerBuilder builder) +656
   Autofac.Module.Configure(IComponentRegistry componentRegistry) +70
   Autofac.ContainerBuilder.Build(IComponentRegistry componentRegistry, Boolean excludeDefaultModules) +113
   Autofac.ContainerBuilder.Build(ContainerBuildOptions options) +53
   Orchard.Environment.OrchardStarter.CreateHostContainer(Action`1 registrations) in c:\Orchard\src\Orchard\Environment\OrchardStarter.cs:132
   Orchard.Web.MvcApplication.HostInitialization(HttpApplication application) in c:\Orchard\src\Orchard.Web\Global.asax.cs:46
   Orchard.WarmupStarter.<>c__DisplayClass3.<LaunchStartupThread>b__2(Object state) in c:\Orchard\src\Orchard.WarmupStarter\Starter.cs:89

[ApplicationException: Error during application initialization]
   Orchard.WarmupStarter.Starter`1.OnBeginRequest(HttpApplication application) in c:\Orchard\src\Orchard.WarmupStarter\Starter.cs:63
   Orchard.Web.MvcApplication.Application_BeginRequest() in c:\Orchard\src\Orchard.Web\Global.asax.cs:29

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
   System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) +192
   System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +108
   System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters) +19
   System.Web.Util.ArglessEventHandlerProxy.Callback(Object sender, EventArgs e) +56
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +136
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69

  


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18449 
Any help would be greatly appreciated. I've done a ton of searching to no avail.

--JJ

Also, here's a link to my latest log file: http://1drv.ms/Ql13Kr
Apr 24, 2014 at 6:03 PM
I'm having the same going from 1.7 to 1.8.
Apr 25, 2014 at 1:50 PM
I'm starting to fear that these boards are dead and no help is coming:/
Developer
Apr 25, 2014 at 2:06 PM
Are you using the source code package or web package? If using source code package, it might be easier to troubleshoot.
If using source code package, can you confirm that the type "CultureDateTimeFormatProvider" is there in Orchard.Framework/localization/Services?
Apr 25, 2014 at 2:59 PM
Edited Apr 25, 2014 at 2:59 PM
I grabbed the zip file and just copied it over with ftp(web package). I did just open my site through VS FTP, and I can't find the file you're referring to.

I've uploaded what I did find, but not sure what to do with it. Hosted on Imgur since it's big.

http://imgur.com/u9Mn3np
Apr 25, 2014 at 3:18 PM
I've just grabbed the source for 1.5.1 and will start digging through as well. Not sure what all I'm looking for, but I plan to dig locally and see what happens. If you have any other advice sfmskywalker, it would be greatly appreciated:) Hell, if we can fix this, I'll buy you a cup of coffee if you have paypal setup!!
Apr 25, 2014 at 3:24 PM
Ok, this is what I've found so far after looking at the source. I've opened Orchard.framework/Localization/Service and not found the "CultureDateTimeFormatProvider"

I did a search with solution explorer for that, and came back with nothing. Now I'm confused:/

Just a quick background, I did attempt an upgrade to 1.8.1, forgot to make a change to the Admin, had to roll back. Did this make a change to my DB that could be causing this?
Apr 25, 2014 at 3:43 PM
Ok, just went through the 1.8 source, and there it is. So now I need to figure out why my 1.5.1 is trying to call to this file.

(btw, I'm also logging every step incase it helps someone else and for my own memory).
Apr 25, 2014 at 6:13 PM
Resolved.

Thanks Arvixe. They closed my ticket saying that they restored my website to the date when I had 1.5.1, they lied. I deleted the Bin Folder, put my backup in place, and it all works. So sorry for the confusion.
Marked as answer by jjmurphypsu on 4/25/2014 at 10:14 AM