This project is read-only.

Upgrade Orchard 1.7.3 to 1.8 Localization Error

Topics: Installing Orchard
Apr 15, 2014 at 4:58 PM
Edited Apr 17, 2014 at 8:26 AM
I'm trying to upgrade my Orchard website from 1.7.1 to latest version.

Upgrades to 17.2 and 1.7.3 works fine.

I have followed steps on this page:
But the upgrade from 1.7.3 to version 1.8 give me an error:

2014-04-15 17:44:03,244 [11] Orchard.Environment.DefaultOrchardHost - (null) - A tenant could not be started: Default
System.TypeLoadException: Could not load type 'Orchard.Core.Shapes.Localization.IDateTimeLocalization' from assembly 'Orchard.Core, Version=, Culture=neutral, PublicKeyToken=null'.
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimeConstructorInfo.get_Signature()
at System.Reflection.RuntimeConstructorInfo.GetParametersNoCopy()
at System.Reflection.RuntimeConstructorInfo.GetParameters()
at Orchard.Caching.CacheModule.<AttachToComponentRegistration>b__0(ConstructorInfo x) in c:\Orchard\src\Orchard\Caching\CacheModule.cs:line 16
at System.Linq.Enumerable.Any[TSource](IEnumerable1 source, Func2 predicate)
at Orchard.Caching.CacheModule.AttachToComponentRegistration(IComponentRegistry componentRegistry, IComponentRegistration registration) in c:\Orchard\src\Orchard\Caching\CacheModule.cs:line 19
at System.EventHandler1.Invoke(Object sender, TEventArgs e)
at Autofac.Core.Registration.ComponentRegistry.AddRegistration(IComponentRegistration registration, Boolean preserveDefaults) in c:\Projects\OSS\autofac\Core\Source\Autofac\Core\Registration\ComponentRegistry.cs:line 171
at Autofac.Core.Registration.ComponentRegistry.Register(IComponentRegistration registration, Boolean preserveDefaults) in c:\Projects\OSS\autofac\Core\Source\Autofac\Core\Registration\ComponentRegistry.cs:line 131
at Autofac.Builder.RegistrationBuilder.RegisterSingleComponent[TLimit,TActivatorData,TSingleRegistrationStyle](IComponentRegistry cr, IRegistrationBuilder
3 builder) in c:\Projects\OSS\autofac\Core\Source\Autofac\Builder\RegistrationBuilder.cs:line 228
at Autofac.ContainerBuilder.Build(IComponentRegistry componentRegistry, Boolean excludeDefaultModules) in c:\Projects\OSS\autofac\Core\Source\Autofac\ContainerBuilder.cs:line 164
at Autofac.Core.Lifetime.LifetimeScope.CreateScopeRestrictedRegistry(Object tag, Action1 configurationAction) in c:\Projects\OSS\autofac\Core\Source\Autofac\Core\Lifetime\LifetimeScope.cs:line 207
at Autofac.Core.Lifetime.LifetimeScope.BeginLifetimeScope(Object tag, Action
1 configurationAction) in c:\Projects\OSS\autofac\Core\Source\Autofac\Core\Lifetime\LifetimeScope.cs:line 179
at Orchard.Environment.ShellBuilders.ShellContextFactory.CreateShellContext(ShellSettings settings) in c:\Orchard\src\Orchard\Environment\ShellBuilders\ShellContextFactory.cs:line 61
at Orchard.Environment.DefaultOrchardHost.<CreateAndActivateShells>b__7(ShellSettings settings) in c:\Orchard\src\Orchard\Environment\DefaultOrchardHost.cs:line 136

Anyone can help me?
Sorry but I'm new to Orchard, I have made a internet research before posting but I didn't find anything about this error.
Apr 15, 2014 at 7:58 PM
Looks like a compilation pb, which source code do you get ? Has you code built ok ?
If you downloaded the 1.8, try another way cloning the 1.8x branch and restart.
Apr 16, 2014 at 8:36 AM
I'm using downloaded from Codeplex.
Apr 28, 2014 at 9:59 AM
Noone can help me please?

I continue to get this error on upgrade.
Jun 2, 2014 at 10:00 AM
Search your codebase for any references to IDateTimeLocalization. I had a similar problem and was using this to access the MonthNames property. It appears this has moved from Orchard.Core.Shapes.Localization.IDateTimeLocalization to Orchard.Localization.Services.IDateTimeFormatProvider.
Jun 4, 2014 at 4:43 PM
Thanks for your reply.
I've tried to:
  • uninstall additional modules -> upgrade to 1.8 -> same error
  • uninstall additional theme (bootstrap) -> upgrade to 1.8 -> same error
If I open the upgraded folder in visual studio and search for IDateTimeLocalization no matches are founded.

Any other idea? :)
Jun 10, 2014 at 9:00 AM
I don't know "why" but I upgraded my orchard correctly:
  • first I have copied only App_Data folder
  • at first startup the website has given an error about prerequisites, but after some refresh was started
  • then I have copied additional modules
  • last I have installed the bootstrap theme, and all works fine
Thanks for support.