This project is read-only.

Weird Taxonomy migration issue (1.6 to 1.7.2)

Topics: Administration, Core, Troubleshooting
Jan 8, 2014 at 9:33 AM
Edited Jan 8, 2014 at 9:36 AM

To give some background, I've hurdled a prior issue before migrating terms in taxonomies by updating the tables:
        UPDATE Contrib_Taxonomies_TermPartRecord
        SET Path = '/' + Path
        WHERE Path NOT LIKE '/%'

        UPDATE Contrib_Taxonomies_TermPartRecord
        SET Path = '/'
        WHERE Path IS NULL
So I've got some content types which have some taxonomies associated to them.

1) I can create new Content Items without associated taxonomy terms (selecting nothing)
2) I can create new Content Items with some specific terms only (haven't seen a pattern in the terms)
3) I can't create/save/publish new Content Items associated to some specific terms (page just tries to load and it's like there's an infinite loop in the background)

Worst part is that no errors are thrown or logged, even in debug mode.

Anyone have any ideas or leads? Has anyone encountered similar behavior before?

Jan 10, 2014 at 11:28 AM
Started a bounty at SO:

Still no idea why this is happening, no errors thrown.
Jan 13, 2014 at 7:08 AM
Tried to step into the code and here is where item 2 and 3 above differ:


Working terms go past that line and onto Services.Notifier. The terms which cause issues stop there and don't throw any errors, it's like an infinite loop.

I went deeper and found the same on the line below, working terms went past that and terms that didn't work just stopped there.


Right now I'm trying to go through the Invoke<TEvents> within InvokeExtensions.cs, because it seems to be having issues there.