Session problem while not signed in as admin

Topics: Writing modules
Jan 6, 2014 at 7:12 PM
Hi!
I'm writing a module for custom authentication and authorization and come up against a problem.
I have a form for login. And all works fine if I am signed in Orchard authentication system as admin. As result it redirects me on home page (http://192.168.1.130:8555) and even after refreshing the page I stay signed in MY authentication system.
Image
But If I'm not signed in Orchard authentication system as admin and I want to sign in MY authentication system, it redirects me on home page but this time URL looks like this http://192.168.1.130:8555/?__r=8d0d926bb27ec36. And after refreshing I should sign in again.
Image

What is "?__r=8d0d926bb27ec36" in URL? and why Session is not saved if I'm not signed in as admin?

Please, I need a help =(
Jan 7, 2014 at 12:16 AM

That part of the url comes from the cache module, a bug in 1.7.2, and shouldn't cause auth problems.

6 Oca 2014 21:13 tarihinde "shemi" <[email removed]> yazdı:

From: shemi

Hi!
I'm writing a module for custom authentication and authorization and come up against a problem.
I have a form for login. And all works fine if I am signed in Orchard authentication system as admin. As result it redirects me on home page (http://192.168.1.130:8555) and even after refreshing the page I stay signed in MY authentication system.
Image
But If I'm not signed in Orchard authentication system as admin and I want to sign in MY authentication system, it redirects me on home page but this time URL looks like this http://192.168.1.130:8555/?__r=8d0d926bb27ec36. And after refreshing I should sign in again.
Image

What is "?__r=8d0d926bb27ec36" in URL? and why Session is not saved if I'm not signed in as admin?

Please, I need a help =(

Read the full discussion online.

To add a post to this discussion, reply to this email ([email removed])

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jan 7, 2014 at 12:04 PM
I've resolved my auth problem by adding ignored urls in cache settings:

/
/Users/Account/

But this "?__r=8d0d926bb27ec36" is still there when I'm not signed in as Admin
Is there a way to get rid off of that part?
Jan 7, 2014 at 12:22 PM
There is an issue reported for this. https://orchard.codeplex.com/workitem/20381 If you vote, it will be dealt with sooner I guess.

I don't know if there are any other attemtps to fix it, but until somebody or orchard team solves it, you can get rid of it by disabling the output cache module.


Jan 7, 2014 at 12:28 PM
I've just read about that issue....
Anyway... thank you for help!
Jun 16, 2014 at 12:42 AM
Just leaving a helpful note here for others that get this 'mysterious' session variable popping up in the url ... it will also break the Orchard pager.