SQLCE Connection String

Topics: Core, General, Installing Orchard
Jan 2, 2014 at 10:47 AM
Edited Jan 2, 2014 at 10:52 AM
I have an Orchard 1.5 site running with a SQL Compact DB but I have the below error -

The database file is larger than the configured maximum database size. This setting takes effect on the first concurrent database connection only. [ Required Max Database Size (in MB; 0 if unknown) = 257 ]

I have added this connection string to the settings.txt file but it has no effect -

DataConnectionString: Data Source=|DataDirectory|\Sites\Default\Orchard.sdf; Max Database Size=1024; Persist Security Info=False;

also tried this -

DataConnectionString: Data Source=\Sites\Default\Orchard.sdf; Max Database Size=1024; Persist Security Info=False;

Orchard seems to be ignoring this as I am still getting the same error and part of the website is throwing 500 errors because of this.

I am a front end developer so please keep suggestions simple. :)
Developer
Jan 2, 2014 at 6:00 PM