Migration from 1.72 to 1.x ?

Topics: General, Installing Orchard, Troubleshooting
Dec 19, 2013 at 8:09 PM
Edited Dec 19, 2013 at 8:10 PM
strictly speaking, the subject ...

I always ( 1.6 - 1.72 ) copy-past App_Data folder in migration .

Now this method is not working ( I suspect that it is because of funky shift :)

Please: Guids, aproaches, advices and anything is welcomed ( except installing from scratch and analyzing each table )
Dec 20, 2013 at 7:08 PM
Edited Dec 20, 2013 at 7:09 PM
Just analized first 10 tables ...
A lot of fields are changed.
So the database is NOT compatible.

Au, Gurus!

There should be content migration script ?
Developer
Dec 20, 2013 at 7:17 PM
If there needs to be an upgrade script, the Upgrade module will be updated just before the next version of Orchard will be released. We don't do that for 1.x, because that's essentially the develop branch.
Dec 20, 2013 at 8:03 PM
Edited Dec 20, 2013 at 8:19 PM
When I copy database from 1.72 to 1.x I got this :
Image



No layouts , no content, no my theme
I even can not go to admin (access is denied)

How I will use "Upgrade module" ?

Yes, I understand that the branch is in developer stage, but such things were not with previous versions
Developer
Dec 20, 2013 at 9:05 PM
Well, its hard to say why it doesn't work for you. All we can do is test the migration path from 1.7.2 to 1.8 just before it's released. To solve your immediate issue, please check the log files to see if there's anything there that might give you some clues. When you start troubleshooting this and need help with understanding what might be going on, please let us know and provide as much relevant detail you can give.
Developer
Dec 20, 2013 at 10:54 PM
Have you enabled the Upgrade module in admin?

There is a tab that allows you to migrate the contents.
Dec 21, 2013 at 9:16 AM
Edited Dec 21, 2013 at 9:36 AM
agriffard wrote:
Have you enabled the Upgrade module in admin?

There is a tab that allows you to migrate the contents.
The problem is that I even can not go to admin.
This screen looks like orchard-death-screen :)

Now I am trying to remove all custom modules (not core) ( except my theme ) in source (1.72) analysing tables (remove all reduntants) and migrate again.

If I install 1.x from scratch over initial screen ( with putting account and choosing database ) over cooking and copy my theme, everything is Ok with empty content and without my custom content types, made in admin.

In other words, my theme is working with initial 1.x database.


To sfmskywalker :

Sorry for offtopic , does your DarkSky Commerce abandoned ?
Developer
Dec 21, 2013 at 10:37 AM
Not abandoned, but on hold until I have time and need for it.