Adding Images

Topics: Customizing Orchard, Writing modules, Writing themes
Dec 14, 2013 at 8:10 PM
I cant quite work out what the deal is with images. Latest version 14 Dec 2013

I can upload the images fine in the Media Library but then I cant quite workout how to use them in the theme. I could put a hard coded link but what i was looking for is more of a edit type box the user then used to select an Image from the Media Library.

I may have the wrong end of the stick here but I'm assuming that's how it works.


Dec 16, 2013 at 7:00 PM
What exactly are you trying to do?
You can insert images in every ContentItem that has an input for HTML.
Dec 17, 2013 at 12:13 AM
I have worked this out now.

The problem it turns out is I was doing it as I thought but the admin system seems to have a few bugs in it.

I basically created a content type as Widget and added a Field of Media Picker.

When you look at the content type the field I have added doesn't show but it has been added to the database because when you try to recreate the field with the same name it wont let you because it already exists.

If I delete the content type and do it again sometimes its there and all is working fine.

This does make it very confusing though as you start to think its just because you are doing it wrong.
Dec 17, 2013 at 12:32 AM
If you found bugs, please file them.
Dec 17, 2013 at 12:40 AM
I have done now.

It was my intention to debug it through Visual Studio as I currently have it in Web Matrix just haven't had the time.