manual deploy CMS Orchard project from WebMarix to Win2008 server?

Topics: Administration, Installing Orchard
Nov 21, 2013 at 3:52 AM
Hello:

I use the WebMatrix to setup CMS Orchard 1.7.x theme. I got a website running from the WebMatrix. I zip the entire MyWebSite project, and copy into the Win2008 server that is currently co-locate. I have the IIS 7.0 point to the MyWebsite folder, but fail to startup MyWebSite.

I try to use Bing and Google, but it doesn't have good answers.

Can someone explain to me how to deploy a CMS Orchard project from WebMatrix into my private web host (Win2008 R2) server?

Thank You
Mike


--------------------------------- Error Msg --------------------------------
HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.


Detailed Error Information

Module

CustomErrorModule



Notification

SendResponse

Handler

NotFound

Error Code

0x80070021

Config Error

This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".



Config File

\?\C:\inetpub\wwwsite\mywebsite\web.config





Requested URL

http://www.mywebsite.com:80/



Physical Path

C:\inetpub\wwwsite\mywebsite

Logon Method

Not yet determined

Logon User

Not yet determined

Config Source 126: <!-- Prevent IIS 7.0 from returning a custom 404/500 error page of its own. -->
127: <httpErrors existingResponse="PassThrough" />
128: <security>
Developer
Nov 21, 2013 at 12:13 PM
What .NET framework is the app pool running on? That needs to be 4.0 or 4.5.
Nov 21, 2013 at 2:43 PM
Yes, I have .Net framework pool and 4.0 and 4.5 install into Win2008 server.

By disable the customize error page entry in the web.config file, I able see the true error. It complain about write access to the Data folder (where database and xml). So, I change security setting to allow IIS access right. Next problem, the IIS complain about access resource. Right now, I am stuck.


Mike
Nov 22, 2013 at 3:45 PM
OK, I got it working.

In the Admin settings, I have "Base Url" localhost for the website because I build a theme in desktop. So, when it move to Win2008 service, forgot to setup "Base Url" to www.mywebsite.com.

Enable host setup:
1) Setup "Base Url" before deploy. Look under Setting->Base Url. Change website name also.
2) Copy entire CMS Orchard web site into Win2008 server.
3) Create a IIS website "thread pool" and point the CMS Orchard website folder.
4) Change Windows 2008 Security that allow IIS User access to the CMS Orchard website folder with "Read/Write" attribute.