This project is read-only.

Deploy 1.7.1 using Azure - Missing SetgIdleTimeout.cmd

Topics: Installing Orchard
Oct 6, 2013 at 1:06 PM
Hi there,

I am following this guide here

I opened the solution, configured everything and then did a Publish, it started to publish but towards the end it states that there is a missing file in the solution \Bin\Startup\SetIdleTimeout.cmd

Sure enough its included in the solution but not present (Yellow triangle).

I did try and remove it and then republish but I got the same error.

Anybody managed to publish orchard to azure ? successfully ? Would appreciate any feedback anyone has

Thanks in advance
Oct 8, 2013 at 12:53 PM
You need to create the file in the Orchard.Azure\Orchard.Azure.CloudService\Orchard.Azure.WebContent\bin\Startup folder

with this content:
REM Unless running in the compute emulator, set the default idle timeout of IIS application pools to zero (no automatic recycling).
IF "%ComputeEmulatorRunning%" == "false" (
    %windir%\system32\inetsrv\appcmd set config -section:applicationPools -applicationPoolDefaults.processModel.idleTimeout:00:00:00
I just tried and then it deploys and works. The other option would be to go to the servicedefinition.csdef and remove this line:
  <Task commandLine="Startup\SetIdleTimeout.cmd" executionContext="elevated" taskType="simple">
Oct 8, 2013 at 6:07 PM
Somehow this file has been removed. What do you suggest ? To add this file back or instead have a more general file name and people could use it to add more commands ?
Oct 9, 2013 at 11:33 AM
Add this file back, and keep the name for now.

If someone wants to add other tasks, that's always possible.
You can run multiple tasks, and the "simple" tasks are run in the order specified.

Custom tasks could also be a background (or foreground) tasks, so you need several .cmd files for this.
Oct 10, 2013 at 8:48 PM
Weird that this file is missing. Agree with Erik, keep the name, other tasks should be in other files.
Oct 10, 2013 at 9:50 PM
OK so I did some checking and as far as I can see the file is present in the repo, and was checked in there long before the 1.7.1 tag. I added the file in changeset 93c628bf on 2013-08-27 which was committed by Sebastien on 2013-08-30.

So why is it not in the file? When was this file created and from which changeset?

Obviously, the zip file does not properly reflect the repo tag 1.7.1 and should be refreshed so people don't get hit by this issue. (Who knows what other changes might be missing from the zip...)
Oct 10, 2013 at 10:43 PM
This turned out to be an issue with the Orchard.proj build file. I fixed it in 1.7.x branch, and Sebastien will update the 1.7.1 zip file with the missing content.
Marked as answer by Decorum on 10/10/2013 at 2:43 PM
Oct 11, 2013 at 12:10 AM
Source Zip has been updated
Oct 12, 2013 at 12:33 PM
Thanks guys for the effort here, I have just deployed my first orchard to azure :-)