Problems importing & deleting images in the Media Library

Topics: Troubleshooting
Sep 7, 2013 at 10:16 AM
Edited Sep 7, 2013 at 11:10 AM

I'm starting to learn how the new Media Library works. In order to do so I've created a new Orchard 1.7 site, next I've created a folder within the Media Library and finally I have attempted to import images through the three sources the Media Library seems to offer.
  • My Computer: If I select a file or drop one, the thumbnail of the image appears in the square to drop or copy files. Eventhough after click at close button I cannot see the image anywhere. However if I filter with the Show combo by "only Images" I can see the images. However if I don't filter "Any (Show All)" nothing appears.
  • Web Search: I've completed a valid key in the Media Settings but I don't get any result after input a search
  • Media Url: I insert an url like following one, but nothing happens
Another issue is that I have tried to remove the imported images but despite It works ok because they are deleted from the file system folder. However, if after delete I select another option to filter the media and after this another time I select "only Images" I can see another time all the deleted images on the screen, it looks a cache problem.

The versión I'm using is Orchard 1.7, I got it this morning from
Sep 7, 2013 at 10:54 AM
Edited Sep 7, 2013 at 10:54 AM
Sorry I made a mistake inserting key for the web search, it works properly :)
The other problems I described still happen.
Sep 7, 2013 at 11:15 AM
Edited Sep 7, 2013 at 11:43 AM
I have observed that if I clean the browser cache and I select "Any (Show All)" I can see all the images ... so all seems to be a cache problem of the knockout.js part of this module that should be solved.
I have filed a bug here

What I'm not sure what is the problem with the option of Media Url because the images I try to import using this method never appear in the folder even cleaning the browser cache. Looking into the code I have seen it expects an oembed format. But testing it with this url it doesn't work:

I don't know too much about oembed format, but won't it be interesting to accept directly image urls to import to media gallery?