Problem with Search/Index/Lucene

Topics: Administration
Aug 15, 2013 at 8:57 PM
I am running 1.7 and have enabled Search, Index and Lucene module. However, every admin page I go to says

"You need to enable an index implementation module like Lucene."

If I disable and re-enable Lucene I see

"You need to enable an index implementation module like Lucene."
"Lucene enabled"

However, no index is being built, no Index/Search directory appears under the Default site, and (obviously) the search box on the web site returns 0 results. Nothing interesting is logged in the error log file either.

I am at a loss here as to what is wrong. Thanks,

Aug 16, 2013 at 4:27 AM
Does this happen with a fresh install of 1.7? Are you using the web package or the source package, or cloning from CodePlex?
Aug 16, 2013 at 9:15 AM
I recently setup Orchard and had this issue too. It was down to me not realising that you need to tick the Content Definitions you want to include in the indexing. Here was my setup of the search function for my blog posts:

1) Turn on Indexing, Search and Lucene modules from the Modules section.

2) go into Settings -> Indexes and click on Create button. I called my index 'SiteIndex'.

3) Next go to Settings -> Search and select the index you just created from the Indexes dropdown and click on Save.

4) Now go to Content Definition and click on edit for Blog. Tick the box to include Blog posts in the index you just created (Index this content type in: SiteIndex) and click save. Do the same with 'Blog Post' option in Content Definition.

5) If you click back to Settings -> Index you should see that it has indexed your blog. If you go to Settings - Search you can filter what elements in your Blog Posts gets indexed. By default the Title and Body are selected but you can add dates, authors, etc.

I thought that Indexing would just work out of the box - not realising that I need to specify what I wanted Indexed. Hopefully that helps! Worked for me ;)

Aug 16, 2013 at 3:30 PM
Thank you for your responses.

sfmskywalker, my install is an upgrade from 1.61, which was installed manually from a ZIP file. However, the search/index features were working following the upgrade to 1.7.

Richard, my problem is that even though I have enabled everything for searching, they are not really enabled. For instance, in Settings, there is no Indexes section, thus no button to create the index. Likewise, there is no Search option either.

There is other strangeness happening now too. IIS periodically shuts down my Orchard site because of too many errors in the worker process. "Total failure" type communications issues. or "Too many errors". I am going to look into that this evening.
Aug 16, 2013 at 5:31 PM
If you are allowed to share you content you can send me a duplicate and I will look into it. Nothing better than a good breakpoint in the middle of the code to see what is happening.
Aug 16, 2013 at 6:29 PM
I really appreciate your offer. What would you need? Zip of the site, or full database?
Aug 16, 2013 at 10:59 PM
site+databse inside a zip, on a website (not by mail), even better if it's a SqlCe database.
Aug 17, 2013 at 5:35 PM
Unfortunately I am not able to do that. I do appreciate the offer very much. At this point, Orchard usually does not complain about enabling Lucene, but there are no indexing options anywhere in the dashboard. There is no SearchSettings.xml file in the AppData folder, nor an Indexes folder anywhere to be seen. The error log is clean. I am at a loss as to what it is looking for...

Aug 18, 2013 at 1:14 AM
All is now good in the world :) Since the site was relatively small, I decided to just kill the old installation and lay down a new Orchard 1.7 in its place. After restoring my configuration and media, everything is now working, including Search/Indexing. I wish I knew what the original problem was, but alas, I needed to move on to other things and am happy it is now working. I do appreciate your help.
Aug 18, 2013 at 4:32 PM
Edited Aug 18, 2013 at 4:34 PM
richardreddy wrote:
I thought that Indexing would just work out of the box (...)
It does with fresh 1.7 install. There's been a quite big change regarding indexing between 1.6 and 1.7 (multiple indexes support), so if you update from earlier versions you need to create indexes manually. The one used by Orchard search engine by default is called "Search".
Aug 19, 2013 at 7:37 PM
There is also a "Recipe" in the new tab of the Modules link which will configure everything with defaults for a search index.
Nov 5, 2013 at 8:38 PM
Hi Sebastien,

So I have a similar issue. We have created multiple indexes, one named "search" and the other named "guides". The only one that works is the search one. When I go into the search settings tab, I can select "search" from the drop down and select the individual fields, however when I select the "guides" from the dropdown there are no selectable fields. What is the expected result if I click execute on the search under the "recipe" tab? Is their a way to have multiple indexes, or are we only able to have one as of now? We are using Orchard v.

Thanks Sebastien - You are much appreciated.
Nov 26, 2013 at 4:26 PM
I've same problem after I've uploaded an 1.7.1 from my dev server to production (Azure).

You need to enable an index implementation module like Lucene.

No way to fix it and start indexing.. ideas?

May 29, 2014 at 2:56 PM
I know this thread is a bit old, but I ran a clean install of 1.8 for a brand new site, enabled Lucene, Search and Indexing but when I go to Settings -> Indexes it tells me no indexes are available and there isn't a create option. I also have that error in admin that says "You need to enable an index implementation module like Lucene." Disabling/enabling Lucene, Search and Indexing didn't do me any good.

Aug 7, 2014 at 1:56 PM
I'm getting a similar error with index's on 1.8 after initially getting error:

Some features need to be upgraded: Orchard.Indexing

I then ran the recipe and now get:

Note: I've just precompiled from the source again and restored the bootstrap theme.

Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS1061: 'Orchard.Indexing.ViewModels.IndexViewModel' does not contain a definition for 'IndexEntries' and no extension method 'IndexEntries' accepting a first argument of type 'Orchard.Indexing.ViewModels.IndexViewModel' could be found (are you missing a using directive or an assembly reference?)

Source Error:

Line 4: @{ Layout.Title = T("Indexes").ToString(); }
Line 5:
Line 6: @if (Model.IndexEntries.Any()) {
Line 7: using (Html.BeginFormAntiForgeryPost()) {
Line 8: <fieldset class="contentItems bulk-items">

Source File: c:\inetpub\websites\lifestylecleaning\Modules\Orchard.Indexing\Views\Admin\Index.cshtml Line: 6

Show Detailed Compiler Output:

c:\windows\system32\inetsrv> "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\csc.exe" /t:library /utf8output /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\a03b2562\acdecc22_9e88cf01\Orchard.Web.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.DynamicData\v4.0_4.0.0.0__31bf3856ad364e35\System.Web.DynamicData.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\57a89fdb\6a0ec610_9c88cf01\System.Web.WebPages.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\021825f9\53a47120_9e88cf01\Orchard.WarmupStarter.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.Routing\v4.0_4.0.0.0__31bf3856ad364e35\System.Web.Routing.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\94bf65e8\5f386e15_9c88cf01\NHibernate.Linq.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\efa93e0b\d4437b11_9c88cf01\Autofac.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\d8f3441b\6bf72e11_9c88cf01\System.Web.Http.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\62af71c2\c15a1211_9c88cf01\System.Net.Http.Formatting.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ComponentModel.DataAnnotations\v4.0_4.0.0.0__31bf3856ad364e35\System.ComponentModel.DataAnnotations.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\App_global.asax.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\55b56ec7\fa803811_9c88cf01\System.Web.Http.WebHost.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Data.SqlServerCe\\System.Data.SqlServerCe.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\7f5b8490\7c5bd215_9c88cf01\FluentNHibernate.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Data.Entity\v4.0_4.0.0.0__b77a5c561934e089\System.Data.Entity.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_6.5.4.0__c5687fc88969c44d\MySql.Data.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\75c99893\f4736b10_9c88cf01\System.Web.Helpers.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\254c7708\e7a9e015_9c88cf01\Iesi.Collections.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscorlib.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\8c4959c0\80be5513_9c88cf01\log4net.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\5d1266d1\fd67df11_9c88cf01\Castle.Core.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Microsoft.CSharp\v4.0_4.0.0.0__b03f5f7f11d50a3a\Microsoft.CSharp.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\App_Web_3yt20plv.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\8f1833ec\ad21d910_9c88cf01\System.Web.WebPages.Razor.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\ea32ee71\32d58c10_9c88cf01\System.Web.Mvc.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Data.Linq\v4.0_4.0.0.0__b77a5c561934e089\System.Data.Linq.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\dba7b987\0ce93354_9d88cf01\Orchard.Core.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\d4e0341e\5a304716_9c88cf01\NHibernate.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_64\System.Web\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\cfa71de4\e3418d50_9d88cf01\Orchard.Framework.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Xml.Linq\v4.0_4.0.0.0__b77a5c561934e089\System.Xml.Linq.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\6bdb0bab\4acf4611_9c88cf01\Autofac.Configuration.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\2e803e9e\9a22ba10_9c88cf01\System.Web.WebPages.Deployment.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Microsoft.Web.Infrastructure\v4.0_1.0.0.0__31bf3856ad364e35\Microsoft.Web.Infrastructure.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\a9ed1888\3cd4ab10_9c88cf01\System.Web.Razor.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Core\v4.0_4.0.0.0__b77a5c561934e089\System.Core.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Data.Entity.Design\v4.0_4.0.0.0__b77a5c561934e089\System.Data.Entity.Design.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\2d7f90b9\bb8ec516_9c88cf01\NuGet.Core.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\7b59ee94\caaba215_9c88cf01\NHibernate.SqlAzure.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\assembly\dl3\5f11bcc4\959c1315_9c88cf01\Newtonsoft.Json.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.Abstractions\v4.0_4.0.0.0__31bf3856ad364e35\System.Web.Abstractions.dll" /out:"C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\App_Web_index.cshtml.74f43f1e.2paya4jo.dll" /D:DEBUG /debug+ /optimize- /w:4 /nowarn:1659;1699;1701;612;618 /warnaserror- "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\App_Web_index.cshtml.74f43f1e.2paya4jo.0.cs" "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\9c8a9d63\6d42a6fb\App_Web_index.cshtml.74f43f1e.2paya4jo.1.cs"

Microsoft (R) Visual C# Compiler version 4.0.30319.17929

for Microsoft (R) .NET Framework 4.5
Copyright (C) Microsoft Corporation. All rights reserved.

c:\inetpub\websites\lifestylecleaning\Modules\Orchard.Indexing\Views\Admin\Index.cshtml(6,12): error CS1061: 'Orchard.Indexing.ViewModels.IndexViewModel' does not contain a definition for 'IndexEntries' and no extension method 'IndexEntries' accepting a first argument of type 'Orchard.Indexing.ViewModels.IndexViewModel' could be found (are you missing a using directive or an assembly reference?)
c:\inetpub\websites\lifestylecleaning\Modules\Orchard.Indexing\Views\Admin\Index.cshtml(10,42): error CS1061: 'Orchard.Indexing.ViewModels.IndexViewModel' does not contain a definition for 'IndexEntries' and no extension method 'IndexEntries' accepting a first argument of type 'Orchard.Indexing.ViewModels.IndexViewModel' could be found (are you missing a using directive or an assembly reference?)
c:\inetpub\websites\lifestylecleaning\Modules\Orchard.Indexing\Views\Admin\Index.cshtml(67,12): error CS1061: 'Orchard.Indexing.ViewModels.IndexViewModel' does not contain a definition for 'IndexProvider' and no extension method 'IndexProvider' accepting a first argument of type 'Orchard.Indexing.ViewModels.IndexViewModel' could be found (are you missing a using directive or an assembly reference?)