This project is read-only.

Bing maps don't work

Topics: Core, Troubleshooting
Jul 10, 2013 at 10:24 PM
I have downloaded Orchard today for the first time.
I tried all the solutions on the various forums, but I can't get the bing maps module to work. I am working with this module as it is featured in your documentation.
I've been able to get the image gallery to work, so I know a little about how to operate the UI.
Jul 10, 2013 at 11:21 PM
Hi and welcome. You'll need to be a little more specific when asking questions. If you want answers, try to specify what you tried, what you expected to happen and how it failed.
Jul 10, 2013 at 11:35 PM
Procedure: as per docs. I also set up the image gallery using the same steps and this works.

Expected: map to appear in content area

Result: The content area was empty, only the title appeared.


Fails in chrome, iexplore, and firefox.

Code fix on this page:

Still fails. I have run out of useful google hits for this issue as far as I know.
Jul 10, 2013 at 11:36 PM
Anything in app_data\logs?

Jul 11, 2013 at 12:10 AM
BertrandLeRoy wrote:
Anything in app_data\logs?
Nothing related to Bing Maps, but the error and debug logs are full of ImageGallery exceptions.

System.NullReferenceException: Object reference not set to an instance of an object.
at Mello.ImageGallery.Services.ImageGalleryService.GetImageGallery(String imageGalleryName) in g:\utilities\CMS\Orchard\src\Orchard.Web\Modules\Mello.ImageGallery\Services\ImageGalleryService.cs:line 127

Which is a matter for another topic of course.
Jul 11, 2013 at 12:27 AM
We'll need more information about what you did in order to determine what went wrong. When you go to the content type editor, can you see the type you created, and if you edit that, can you see the map part?
Jul 12, 2013 at 9:21 PM
I followed the steps on this page:

I did the same steps for the gallery and bing maps. The bing maps UI (long, lat, etc) shows up on the page settings, but there is no enable checkbox. The UI for the gallery is also present, and it has an enable checkbox. The gallery appears on the page, but the bing map doesn't. That's about all I know. It appears to be a bug in the bing maps module, but I don't know.
Jul 13, 2013 at 8:58 AM
I'm not sure I understand what you're saying but yes, it's possible that this extremely old module doesn't work with the latest.
Aug 24, 2013 at 2:21 AM
OK, I finally checked the module from the gallery, and it works just fine on 1.7. You must have forgotten to do something. I need to see, step by step, exactly what you did from a vanilla Orchard install.