Does anybody have successfully migrated its 1.x media to last taxo remove ?

Topics: Customizing Orchard, Troubleshooting
Jul 4, 2013 at 2:14 PM
Edited Jul 4, 2013 at 2:42 PM
I try deleting the media sql files, removing the migration record, removing mappings, stopping site, remove dependencies,clean+build and still not coming on my breakpoint in Orchard Medialibrary migration ?
Orchard is very solid...too for an admin as me.

Then going on Media menu gives this
GenericADOException thrown from IContentHandler by Orchard.MediaLibrary.Handlers.MediaPartHandler
NHibernate.Exceptions.GenericADOException: could not load an entity: [Orchard.MediaLibrary.Models.MediaPartRecord#181][SQL: SELECT mediapartr0_.Id as Id390_0_, mediapartr0_.MimeType as MimeType390_0_, mediapartr0_.Caption as Caption390_0_, mediapartr0_.AlternateText as Alternat4_390_0_, mediapartr0_.FolderPath as FolderPath390_0_, mediapartr0_.FileName as FileName390_0_ FROM Orchard_MediaLibrary_MediaPartRecord mediapartr0_ WHERE mediapartr0_.Id=?] ---> System.Data.SqlServerCe.SqlCeException: The specified table does not exist. [ Orchard_MediaLibrary_MediaPartRecord ]


Is it normal that Orchard could continue running when 4 tables related to an activated module have been deleted ?
Developer
Jul 4, 2013 at 3:13 PM
Edited Jul 4, 2013 at 3:41 PM
I managed to migrate to the last version :
  • Disable the Media Library module
  • Delete the table Orchard_MediaLibrary_MediaPartRecord
  • In the table 'Orchard_Framework_DataMigrationRecord', delete the corresponding line with the key 'Orchard.MediaLibrary.MediaDataMigration'
  • In the table 'Settings_ShellFeatureStateRecord', delete the line corresponding to 'Orchard.MediaLibrary'
  • Reenable the Media Library module
  • Enable the Upgrade module and reimport the medias.
Jul 4, 2013 at 4:07 PM
Merci Antoine, will try deleting record in ShellfeatureStateReord, step I missed.
Jul 4, 2013 at 4:26 PM
Seems Ok
Do you know why the new Mediapart migration returns 2 and not 1 ?