This project is read-only.

Any installed module claims it needs updating, does not work (throws errors)

Topics: Administration, Customizing Orchard
Apr 15, 2013 at 8:11 PM
Any module I have installed in the last day or two has claimed it needs updating. For example, when I install any Photo Gallery, I get the following error:
Some features need to be upgraded: Amba.ImagePowerTools
When I try to “upgrade” the module in question, I get the following error:
An error occured while updating the feature Amba.ImagePowerTools: Exception has been thrown by the target of an invocation.
When I try to use the module, it throws massive errors even on its admin section. Orchard Image Gallery 1.3, in particular, completely ceased to function once I tried to enter a category/name for a gallery.

I have made sure that both my application pools as well as IIS have full permissions on the directory. My Orchard installation is mostly vanilla, with very few modifications.
Apr 16, 2013 at 1:42 AM
Check the error logs :)
Apr 16, 2013 at 4:02 AM
Turns out it was a strange issue with the SQL Server. I have Windows Authentication enabled and set as the only way to access the DB, but the old SQL Server Authentication account (used to set everything up, and still there because it refuses to be deleted) is the account which needed to have its old permissions re-established. When I switched over from mixed authentication to Windows Auth, I tried to delete the old SA account, but couldn’t (by this time I had renamed it, and it was in use by a db, so it was “locked” and unable to be deleted). I then decided to modify it so it acted as NT AUTHORITY\NETWORK SERVICE. Much later on (a few weeks ago, in fact) I was trying to install another ASP.NET MVC CMS, and was fiddling around with stuff in SQL Server. I must have un-done something under this strange account because suddenly Orchard issues started cropping up. When I went into that modified SA account today, and checked off the four basic role memberships for the DB in question (datareader, datawriter, owner & securityadmin), suddenly everything started working again.
Apr 17, 2013 at 12:41 AM
Weird, I have also encountered some funny issues with SQL server authentication, although none so far with Orchard. I'm sure it will happen at some point.

Good to hear it is all working though