New Orchard Setup doesn't display theme

Topics: Installing Orchard
Mar 12, 2013 at 2:32 PM
I have setup a new Orchard web site. but the theme doesn't display on a Home page of Orchard. btw it looks ok on the Orchard setup site and an Admin Dashboard. Does anyone experience this issue? Please suggest me.

Image
Image
Image
Coordinator
Mar 13, 2013 at 12:12 AM
Apparently, others who had this problem were able to fix it by upgrading to 1.6. What version is this?
Mar 13, 2013 at 5:44 AM
I have checked the version number which is displayed on the bottom right of my admin dashboard.
Image

Currently, I am packaging an Orchard site which included my own development modules. I use the way to package published files from an Orchard.Web. After placing the published files to a deployment server, then I run and browse to the Orchard application, then set up the Orchard application (Name the site, put the admin password, connection strings and select a recipe). It gets me to a Home page of Orchard which the theme doesn't display in the first image. Is it related to CSS and images? Please suggest me.
Coordinator
Mar 13, 2013 at 6:01 AM
Anything in app_data\logs?
Mar 13, 2013 at 6:06 AM
Yes, there is orchard-debug-2013.03.13.log with a below contents inside.

2013-03-13 11:17:36,379 [16] Orchard.FileSystems.AppData.AppDataFolder - Could not delete recipe execution folder C:\Euronome.Web\Euronome.Web\App_Data\RecipeQueue\1efedf8fdb824204a4b8cd99409b8fd5 under "App_Data" folder
Coordinator
Mar 13, 2013 at 6:20 AM
That shouldn't be blocking. Can you view source on the home page and then get the URL of one of the resources, for example the stylesheet, and open that in a separate tab (or inspect the request in your browser's dev tools' network tab). You will probably get an error message. What is this message?
Mar 13, 2013 at 7:38 AM
It gets me to HTTP Error 500 when I requested for http://localhost:8080/Themes/TheThemeMachine/Styles/Site.css.
Image

When I was using a Dev Tools inside Chrome it was showing me the status of Site.css was canceled in a below image.
Image

It got a same message when I went to Network Tab of Dev-tools > Headers and got "Status Code:500 Internal Server Error"
Please suggest me.
Coordinator
Mar 13, 2013 at 7:48 AM
Please enable custom errors and try again.
Mar 13, 2013 at 8:53 AM
I did enable this in a web.config

<customErrors mode="On" />

but it shown nothing different. How to get into the details of the error after enabling it?

or

Do you mean to disable friendly error page on a browser? I am using Chrome, How to do that?
Developer
Mar 13, 2013 at 2:00 PM
It should be: <customErrors mode="Off" />
Mar 14, 2013 at 5:09 AM
Thank you BertrandLeRoy and sfmskywalker for suggestions. I have found that there is a web.config under a folder \Themes\TheThemeMachine which I guess it normally shouldn't have. Here is a detail of that web.config file.
<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="system.web.webPages.razor" type="System.Web.WebPages.Razor.Configuration.RazorWebSectionGroup, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
      <remove name="host" />
      <remove name="pages" />
      <section name="host" type="System.Web.WebPages.Razor.Configuration.HostSection, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
      <section name="pages" type="System.Web.WebPages.Razor.Configuration.RazorPagesSection, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
    </sectionGroup>
  </configSections>

  <appSettings>
    <add key="webpages:Enabled" value="false" />
  </appSettings>

  <system.web.webPages.razor>
    <host factoryType="System.Web.Mvc.MvcWebRazorHostFactory, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    <pages pageBaseType="Orchard.Mvc.ViewEngines.Razor.WebViewPage">
      <namespaces>
        <add namespace="System.Web.Mvc" />
        <add namespace="System.Web.Mvc.Ajax" />
        <add namespace="System.Web.Mvc.Html" />
        <add namespace="System.Web.Routing" />
        <add namespace="System.Web.WebPages" />
        <add namespace="System.Linq"/>
        <add namespace="System.Collections.Generic"/>
        <add namespace="Orchard.Mvc.Html"/>
      </namespaces>
    </pages>
  </system.web.webPages.razor>

  <system.web>
    <httpHandlers>
      <!-- iis6 - for any request in this location, return via managed static file handler -->
      <add path="*/Theme.png" verb="*" type="System.Web.StaticFileHandler" />
      <add path="*/ThemeZonePreview.png" verb="*" type="System.Web.StaticFileHandler" />
    </httpHandlers>
    <!--
        Enabling request validation in view pages would cause validation to occur
        after the input has already been processed by the controller. By default
        MVC performs request validation before a controller processes the input.
        To change this behavior apply the ValidateInputAttribute to a
        controller or action.
    -->
    <pages
        validateRequest="false"
        pageParserFilterType="System.Web.Mvc.ViewTypeParserFilter, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL"
        pageBaseType="System.Web.Mvc.ViewPage, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL"
        userControlBaseType="System.Web.Mvc.ViewUserControl, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL">
      <controls>
        <add assembly="System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL" namespace="System.Web.Mvc" tagPrefix="mvc" />
      </controls>
    </pages>
    <compilation targetFramework="4.0">
      <assemblies>
        <add assembly="System.Web.Abstractions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Web.Routing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        <add assembly="System.Web.WebPages, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      </assemblies>
    </compilation>
  </system.web>

  <system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <handlers accessPolicy="Script,Read">
      <!--
        iis7 - for any request to a file exists on disk, return it via native http module.
        accessPolicy 'Script' is to allow for a managed 404 page.
        -->
      <add name="ThemePreviewImage" path="*/Theme.png" verb="*" modules="StaticFileModule" preCondition="integratedMode" resourceType="File" requireAccess="Read" />
      <add name="ThemeZonePreviewImage" path="*/ThemeZonePreview.png" verb="*" modules="StaticFileModule" preCondition="integratedMode" resourceType="File" requireAccess="Read" />
    </handlers>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="2.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>
After removing this web.config file from the folder. The site became looking good.
Image
Developer
Mar 14, 2013 at 11:31 AM
Actually I think it is there intentionally, it's here on my machine too, not giving an error.
Since removing it works fine, I guess all is fine, but if you are wondering why the web.config file in the TheThemeMachine caused the error, you should be able to find out by turning customErrors="Off" in the web.config file in the root of the application and see what the exception is (alternatively, an ASP.NET exception is probably being logged in the Event Viewer).
Mar 14, 2013 at 12:30 PM
Thank you BertrandLeRoy and sfmskywalker for suggestions. I have found that there is a web.config under a folder \Themes\TheThemeMachine which I guess it normally shouldn't have. Here is a detail of that web.config file.
<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="system.web.webPages.razor" type="System.Web.WebPages.Razor.Configuration.RazorWebSectionGroup, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
      <remove name="host" />
      <remove name="pages" />
      <section name="host" type="System.Web.WebPages.Razor.Configuration.HostSection, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
      <section name="pages" type="System.Web.WebPages.Razor.Configuration.RazorPagesSection, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
    </sectionGroup>
  </configSections>

  <appSettings>
    <add key="webpages:Enabled" value="false" />
  </appSettings>

  <system.web.webPages.razor>
    <host factoryType="System.Web.Mvc.MvcWebRazorHostFactory, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    <pages pageBaseType="Orchard.Mvc.ViewEngines.Razor.WebViewPage">
      <namespaces>
        <add namespace="System.Web.Mvc" />
        <add namespace="System.Web.Mvc.Ajax" />
        <add namespace="System.Web.Mvc.Html" />
        <add namespace="System.Web.Routing" />
        <add namespace="System.Web.WebPages" />
        <add namespace="System.Linq"/>
        <add namespace="System.Collections.Generic"/>
        <add namespace="Orchard.Mvc.Html"/>
      </namespaces>
    </pages>
  </system.web.webPages.razor>

  <system.web>
    <httpHandlers>
      <!-- iis6 - for any request in this location, return via managed static file handler -->
      <add path="*/Theme.png" verb="*" type="System.Web.StaticFileHandler" />
      <add path="*/ThemeZonePreview.png" verb="*" type="System.Web.StaticFileHandler" />
    </httpHandlers>
    <!--
        Enabling request validation in view pages would cause validation to occur
        after the input has already been processed by the controller. By default
        MVC performs request validation before a controller processes the input.
        To change this behavior apply the ValidateInputAttribute to a
        controller or action.
    -->
    <pages
        validateRequest="false"
        pageParserFilterType="System.Web.Mvc.ViewTypeParserFilter, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL"
        pageBaseType="System.Web.Mvc.ViewPage, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL"
        userControlBaseType="System.Web.Mvc.ViewUserControl, System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL">
      <controls>
        <add assembly="System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL" namespace="System.Web.Mvc" tagPrefix="mvc" />
      </controls>
    </pages>
    <compilation targetFramework="4.0">
      <assemblies>
        <add assembly="System.Web.Abstractions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Web.Routing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        <add assembly="System.Web.WebPages, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      </assemblies>
    </compilation>
  </system.web>

  <system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <handlers accessPolicy="Script,Read">
      <!--
        iis7 - for any request to a file exists on disk, return it via native http module.
        accessPolicy 'Script' is to allow for a managed 404 page.
        -->
      <add name="ThemePreviewImage" path="*/Theme.png" verb="*" modules="StaticFileModule" preCondition="integratedMode" resourceType="File" requireAccess="Read" />
      <add name="ThemeZonePreviewImage" path="*/ThemeZonePreview.png" verb="*" modules="StaticFileModule" preCondition="integratedMode" resourceType="File" requireAccess="Read" />
    </handlers>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="2.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>
After removing this web.config file from the folder. The site became looking good.
Image
Mar 14, 2013 at 1:00 PM
Hi sfmskywalker, Thank you for suggestion. I decided to remove it because there is no web.config file under that folder by installing Orchard via a WebMatrix and the site looks good.

To check what's a root cause of this. When I turned the customError = Off and put the web.config back to the folder. It became the same looking at the problem began, but it didn't generate an ASP.NET exception.
Image

When I was looking at an Event Viewer. there are events related to ASP.NET with below details.
Log Name:      Application
Source:        ASP.NET 4.0.30319.0
Date:          3/14/2013 16:49:12
Event ID:      1315
Task Category: Web Event
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      KAWIN7-CLIENT.euronome.local
Description:
Event code: 4005 
Event message: Forms authentication failed for the request. Reason: The ticket supplied was invalid. 
Event time: 3/14/2013 16:49:12 
Event time (UTC): 3/14/2013 09:49:12 
Event ID: 564a5474d4334faca2ddf4286a92ec9d 
Event sequence: 4 
Event occurrence: 1 
Event detail code: 50201 
 
Application information: 
    Application domain: f1076b1c-1-130077240617942898 
    Trust level: Full 
    Application Virtual Path: /OrchardLocal 
    Application Path: C:\Euronome\Testprojekt\Orchard_1.6\src\Orchard.Web\ 
    Machine name: KAWIN7-CLIENT 
 
Process information: 
    Process ID: 3572 
    Process name: WebDev.WebServer40.exe 
    Account name: EURONOME\ka 
 
Request information: 
    Request URL: http://localhost:30320/OrchardLocal/external-dashboard 
    Request path: /OrchardLocal/external-dashboard 
    User host address: ::1 
    User:  
    Is authenticated: False 
    Authentication Type:  
    Thread account name: EURONOME\ka 
 
Name to authenticate:  
 
Custom event details: 

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="16384">1315</EventID>
    <Level>4</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-03-14T09:49:12.000000000Z" />
    <EventRecordID>34955</EventRecordID>
    <Channel>Application</Channel>
    <Computer>KAWIN7-CLIENT.euronome.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>4005</Data>
    <Data>Forms authentication failed for the request. Reason: The ticket supplied was invalid.</Data>
    <Data>3/14/2013 16:49:12</Data>
    <Data>3/14/2013 09:49:12</Data>
    <Data>564a5474d4334faca2ddf4286a92ec9d</Data>
    <Data>4</Data>
    <Data>1</Data>
    <Data>50201</Data>
    <Data>f1076b1c-1-130077240617942898</Data>
    <Data>Full</Data>
    <Data>/OrchardLocal</Data>
    <Data>C:\Euronome\Testprojekt\Orchard_1.6\src\Orchard.Web\</Data>
    <Data>KAWIN7-CLIENT</Data>
    <Data>
    </Data>
    <Data>3572</Data>
    <Data>WebDev.WebServer40.exe</Data>
    <Data>EURONOME\ka</Data>
    <Data>http://localhost:30320/OrchardLocal/external-dashboard</Data>
    <Data>/OrchardLocal/external-dashboard</Data>
    <Data>::1</Data>
    <Data>
    </Data>
    <Data>False</Data>
    <Data>
    </Data>
    <Data>EURONOME\ka</Data>
    <Data>
    </Data>
  </EventData>
</Event>
Mar 14, 2013 at 1:01 PM
Hi sfmskywalker, Thank you for suggestion. I decided to remove it because there is no web.config file under that folder by installing Orchard via a WebMatrix and the site looks good.

To check what's a root cause of this. When I turned the customError = Off and put the web.config back to the folder. It became the same looking at the problem began, but it didn't generate an ASP.NET exception.
Image

When I was looking at an Event Viewer. there are events related to ASP.NET with below details.
Log Name:      Application
Source:        ASP.NET 4.0.30319.0
Date:          3/14/2013 16:49:12
Event ID:      1315
Task Category: Web Event
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      KAWIN7-CLIENT.euronome.local
Description:
Event code: 4005 
Event message: Forms authentication failed for the request. Reason: The ticket supplied was invalid. 
Event time: 3/14/2013 16:49:12 
Event time (UTC): 3/14/2013 09:49:12 
Event ID: 564a5474d4334faca2ddf4286a92ec9d 
Event sequence: 4 
Event occurrence: 1 
Event detail code: 50201 
 
Application information: 
    Application domain: f1076b1c-1-130077240617942898 
    Trust level: Full 
    Application Virtual Path: /OrchardLocal 
    Application Path: C:\Euronome\Testprojekt\Orchard_1.6\src\Orchard.Web\ 
    Machine name: KAWIN7-CLIENT 
 
Process information: 
    Process ID: 3572 
    Process name: WebDev.WebServer40.exe 
    Account name: EURONOME\ka 
 
Request information: 
    Request URL: http://localhost:30320/OrchardLocal/external-dashboard 
    Request path: /OrchardLocal/external-dashboard 
    User host address: ::1 
    User:  
    Is authenticated: False 
    Authentication Type:  
    Thread account name: EURONOME\ka 
 
Name to authenticate:  
 
Custom event details: 

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="16384">1315</EventID>
    <Level>4</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-03-14T09:49:12.000000000Z" />
    <EventRecordID>34955</EventRecordID>
    <Channel>Application</Channel>
    <Computer>KAWIN7-CLIENT.euronome.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>4005</Data>
    <Data>Forms authentication failed for the request. Reason: The ticket supplied was invalid.</Data>
    <Data>3/14/2013 16:49:12</Data>
    <Data>3/14/2013 09:49:12</Data>
    <Data>564a5474d4334faca2ddf4286a92ec9d</Data>
    <Data>4</Data>
    <Data>1</Data>
    <Data>50201</Data>
    <Data>f1076b1c-1-130077240617942898</Data>
    <Data>Full</Data>
    <Data>/OrchardLocal</Data>
    <Data>C:\Euronome\Testprojekt\Orchard_1.6\src\Orchard.Web\</Data>
    <Data>KAWIN7-CLIENT</Data>
    <Data>
    </Data>
    <Data>3572</Data>
    <Data>WebDev.WebServer40.exe</Data>
    <Data>EURONOME\ka</Data>
    <Data>http://localhost:30320/OrchardLocal/external-dashboard</Data>
    <Data>/OrchardLocal/external-dashboard</Data>
    <Data>::1</Data>
    <Data>
    </Data>
    <Data>False</Data>
    <Data>
    </Data>
    <Data>EURONOME\ka</Data>
    <Data>
    </Data>
  </EventData>
</Event>
Coordinator
Mar 14, 2013 at 6:48 PM
That's really interesting. Would you mind filing a bug with those details? Thanks!
Mar 15, 2013 at 7:56 AM
Hi BertrandLeRoy,

Thanks. Maybe yes, if you are thinking it is. The src of Orchard that I am working on came from another developer. I am not sure why this web.config was needed to be created. I need to ask him about this. Thank you for your times.
Mar 15, 2013 at 9:39 AM
I am also running 1.6. No theming...

You can see it here: http://www.marklybrand.com

I will try to carve out some time to talk to the Arvixe folks... but something tells me that there is some config that I have not enable and it is not step-by-step'ed in the instructions. It would be nice if the instructions could be sort of "for dummies" for completing this task. I am willing to write this up and add it to the orchard documentation if some folks are willing to hold my hand while I do it. Then we could document some common issues that folks might encounter when trying to set up the site (permissions, etc) Betrand? SkyWalker? Are you guys willing if I write everything up in the simplest steps possible. We can post the steps here for feedback and maybe incorporate comments into a guide that can address many issues. I think this could help with adoption of Orchard as a viable CMS :)
Coordinator
Mar 15, 2013 at 11:01 PM
Yes, absolutely, the documentation is on GitHub and is open-source as well. Your contributions are more than welcome.
Apr 13, 2013 at 10:52 PM
Hello,

I am seeing the exact same thing on Arvixe.....

Did anyone write up the steps to solve this? It doesn't have to be a literary masterpiece.... I'm just looking for some things to try.

I appreciate your help!

Thanks,

ED
Apr 15, 2013 at 4:15 AM
Edited Apr 15, 2013 at 4:15 AM
I found the solution.......

In the Arvixe control panel Web Site Properties, go to the Extensions tab...

Set the ASP.NET to 4.0 (Integrated Pipeline)

Click the Update button.....

The problem was....

I had ASP.NET set to 4.0 NOT 4.0 (Integrated Pipeline)

If changing the ASP.NET to 4.0 (Integrated Pipeline) DOES NOT work.....

Look at your folder permissions.

All The Best,

ED
Apr 22, 2013 at 3:52 AM
I already had my Arvixe hosting set to use ASP.NET 4.0 Integrated, but I still wasn't seeing my updates to Site.css being used from the Themes/TheThemeMachine/Styles folder.
I renamed Web.config to Web.config.old (essentially removing it) and refreshed the site. I got a bare-bones look and feel. I renamed it back to Web.config again and refreshed and my site now used my updates to the Site.css file. Something about the Web.config is causing it not see the Site.css in the Themes folder (and use a default version it has somewhere).
Mine's working now.
Ted