Orchard 1.6 not working on host environment

Topics: Installing Orchard
Jan 23, 2013 at 8:21 PM

Hey Guys

I'm trying to install the new Version of 1.6 on my host, but i just don't get it working!

It's running ASP.NET 4 in Full Trust.

When i want to see my site i get this error:

Unable to obtain public key for StrongNameKeyPair.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.ArgumentException: Unable to obtain public key for StrongNameKeyPair.

Source Error: 

Line 6:      var contentTypeClassName = ((string)Model.ContentItem.ContentType).HtmlClassify();
Line 7:  }
Line 8:  @Display(Model.Header)
Line 9:  @Display(Model.Content)

I have seen some other posts facing this topic, but there was no solution that worked for me, so i wanted to ask if there is by any chance something to do against that.


thanks a lot

Jan 27, 2013 at 11:36 AM

Alright... i could fix it, but the way it happened can't be a solution.

My Hosting Provider had to grant me special Rights to the RSA folder.

I just can hope that this gets fixed somehow that it's not a requirement anymore.

Jan 31, 2013 at 8:00 AM
It has never been a requirement and never will be. The workaround you applied is not good. Instead, I think you should just set-up a machine key: http://docs.orchardproject.net/Documentation/Setting-up-a-machine-key
Feb 2, 2013 at 5:10 PM
Thanks for your response.
I added a key as described in the Documentation, but that didn't help at all.. i still got the same error!
I don't understand this!!! Why can't this just work :(
Feb 3, 2013 at 7:34 AM
Never seen that problem before. Your hosting provider must have some weird configuration causing this.