This project is read-only.

Blogposts don't display proper after upgrade to 1.6

Topics: Customizing Orchard
Dec 19, 2012 at 11:54 AM

Hey everyone,

After I upgraded my site to 1.6 my blogs don't display proper anymore.

It seems that <article class="content-item @contentTypeClassName">

the contenTypeClassName has been changed from content-item blogpost to content-item blog

That's why my alternates I created with shapetracer don't work anymore.

Does anyone know where I can change this back?


Dec 19, 2012 at 2:14 PM

Hmm, seems I was wrong..

When I inspect with firebug i seem to have lost my shapeId's:

This was before 1.6

<div class="zone zone-content" shape-id="10">

<article class="content-item blog-post" shape-id="0">

And this is after:

<div class="zone zone-content">

<article class="content-item blog-post">

Does anyone know how I can restore this?

Dec 19, 2012 at 3:17 PM

So Shape Tracing is enabled, and yet it doesn't generate the shape-id attributes? I tried, but it works for me. Perhaps anything in the logs?

Dec 19, 2012 at 3:22 PM


In one I had traceshaper enabled, in the other I didn't so that's why I didn't see the shape ID's... pretty dumb but I have so much windows open I get confused :)

So that's not the problem, I can't figure it out, somehow an alternate isn't being used, the detail of the blogpost

You can see the difference here (1.5)



Dec 19, 2012 at 3:26 PM

It happens :)

I can't say why your alternate isn't being used. What you could do is find the code that generates the alternate, set a breakpoint and make sure that the code that should generate the alternate is actually hit. If not, perhaps there's a feature you still need to enable.

Dec 19, 2012 at 3:51 PM


The only thing I see different is that in the old version the content zone shape-id has a value of 10 and the new one has a value of 5...

Dec 19, 2012 at 10:44 PM

I finaly solved it, very strange, I ended up creating a new alternate via shapetracer, copied my code in and it worked again.

But there seems to be a bug, I found that in another forumtopic also that shapetracer show that the active alternate being used is the wrong one, that made me think that the template wasn't being used.

Do you know about this bug?

Dec 19, 2012 at 11:59 PM

It's not clear what the bug is. What are the repro steps?

Dec 20, 2012 at 8:35 AM

Well, if you create an alternate with shapetracer and add your code it works fine.

but if you go back and inspect it again with shapetracer after you've changed the code you still see the old template active.

Dec 28, 2012 at 9:06 AM

OK, thanks. Please file a bug then.