Deployment issue: Method not found

Topics: Core, Installing Orchard
Nov 15, 2012 at 1:29 AM

I have version 1.51 running (I haven't upgraded to 1.6 as an initial attempt caused all hell to break loose). In production it is great. I deploy it live to a *.example.com subdomain. I run the site, and I get "

Method not found: 'Int32 System.Environment.get_CurrentManagedThreadId()'

I have verified that the site has a v4.5 app pool, the target framework is 4.5, and everything else seems fin (IIS 7.0 btw). Any ideas?

Stack Trace:


[MissingMethodException: Method not found: 'Int32 System.Environment.get_CurrentManagedThreadId()'.]
   Orchard.Logging.d__13..ctor(Int32 <>1__state) +0
   Orchard.Logging.LoggingModule.BuildLoggerInjectors(Type componentType) +67
   Orchard.Logging.LoggingModule.AttachToComponentRegistration(IComponentRegistry componentRegistry, IComponentRegistration registration) in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard\Logging\LoggingModule.cs:32
   Autofac.Module.AttachToRegistrations(IComponentRegistry componentRegistry) +96
   Autofac.Module.Configure(IComponentRegistry componentRegistry) +92
   Autofac.ContainerBuilder.Build(IComponentRegistry componentRegistry, Boolean excludeDefaultModules) +113
   Autofac.ContainerBuilder.Build(ContainerBuildOptions options) +53
   Orchard.Environment.OrchardStarter.CreateHostContainer(Action`1 registrations) in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard\Environment\OrchardStarter.cs:136
   Orchard.Environment.OrchardStarter.CreateHost(Action`1 registrations) in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard\Environment\OrchardStarter.cs:176
   Orchard.Web.MvcApplication.HostInitialization(HttpApplication application) in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard.Web\Global.asax.cs:54
   Orchard.WarmupStarter.<>c__DisplayClass3.b__2(Object state) in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard.WarmupStarter\Starter.cs:89

[ApplicationException: Error during application initialization]
   Orchard.WarmupStarter.Starter`1.OnBeginRequest(HttpApplication application) in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard.WarmupStarter\Starter.cs:63
   Orchard.Web.MvcApplication.Application_BeginRequest() in c:\Users\Tragerforth\Desktop\Dropbox\Development\VanHelSkeetApps\v1.7\src\Orchard.Web\Global.asax.cs:37

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
   System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks) +208
   System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +28
   System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters) +21
   System.Web.Util.ArglessEventHandlerProxy.Callback(Object sender, EventArgs e) +57
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +142
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69


Coordinator
Nov 16, 2012 at 9:29 PM

Are you running full trust?

Nov 23, 2012 at 5:27 PM

Yes, Sir. I have the trust level as "Full" in web.config and am still getting this problem. I have deployed it to a root site (not the subdomain), and get the same problem (not like that should solve anything, but worth a shot).

 

Any ideas?

 

You can view my progress regarding this issue at : http://flashfeed.me

Developer
Nov 24, 2012 at 11:23 AM

I'm really not into IIS but I think if your hoster or your server's global settings don't allow full trust your site won't run in FT even if you have it configured in your Web.config.