Cannot build and run 1.6 source

Topics: General, Installing Orchard, Troubleshooting
Oct 27, 2012 at 9:26 PM

Hi guys - very excited about 1.6 release, I am just starting a new project with it today.

Unfortunately, I cannot get the new source running. I am in VS 2010, using changeset 6677 for the source, open the Orchard.sln file in VS and Ctl-F5 to run. The welcome / cook recipe screen never appears, the Log directory isn't created and no events are written to the event log. I'm on Windows 7.

Am I missing a new dependency (mvc 4 maybe)? Has this happened to anyone else?

I really don't know what to do since this is the straight-up source pulled right from the codeplex today.




Oct 27, 2012 at 9:44 PM
Edited Oct 27, 2012 at 9:45 PM

The Dependencies come with the solution, so no special stuff needed.

Does the solution compile? Is there any errors on compilation?

Also, what is changeset 6677? Did you download from ? note the changeset numbers don't look anything like the one you have!

Oct 27, 2012 at 10:03 PM

Thanks for the reply. In HG Workbench the latest changeset / rev version I see is 6677 for 1.6 release.

I am installing .NET 4.5 and MVC 4 to see if that will get it going. I'll update you on the results!


Oct 27, 2012 at 10:34 PM

Orchard doesn't need 4.5, and doesn't need to install ASP.NET MVC as it's shipped with it.

Oct 27, 2012 at 11:47 PM

Hi guys - well, I installed the newest .NET framework and MVC 4 (I did this before your reply Sebastien!). restart, open solution, run. My first result was a plain text page with the message "Server is too busy" (!?), then I refreshed and guess what - welcome screen as expected.

Who knows, weird, whatever - I'm up and running now. Love the project, and really appreciate the community & support.


Oct 28, 2012 at 9:57 AM

I am glad its working for you.