Thinking of migrating from PHP Wordpress to ASP.NET MVC 4 Orchard

Topics: Installing Orchard, Troubleshooting
Oct 11, 2012 at 9:20 AM

A mamouth task I know...


V1.5 Orchard does not support ASP.NET MVC4, According to blog post V1.6 will.

Should I wait for V1.6 before I get stuck in? I've never used Orchard before, and have no idea how seamless the upgrade from 1.5 to 1.6 will be whilst also changing from MVC 3 to MVC 4

I am aware that I can download source code now, and have downloaded this, but when I load it in VS2012, I get a lot of errors and VS fails to load the solution...

How easy will it be to upgrade from it to update from Orchard 1.5 MVC3 to Orchard 1.6 MVC4?

Oct 11, 2012 at 3:56 PM

Seeing how close 1.6 is to shipping, yes, I would wait if I were you and if you can. You can still start building your theme if you need to, in the meantime, stuff like that.

What kind of errors are you getting in VS? This should just work. Please describe exactly what you did.