Running Orchard in Azure Emulator failed

Topics: Administration, Core
Oct 10, 2012 at 2:07 AM

Running latest version of Orchard (commit bc14927cf187) in Azure emulator failed with error (see below). Some version in regular mode and Orchard 1.5.1 in Azure emulator and regular modes running without any exceptions. 

Any help would be appreciated.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Section or group name 'system.web.webPages.razor' is already defined. Updates to this may only occur at the configuration level where it is defined.

Source Error:

Line 3:  
Line 4:    <configSections>
Line 5:      <sectionGroup name="system.web.webPages.razor" type="System.Web.WebPages.Razor.Configuration.RazorWebSectionGroup, System.Web.WebPages.Razor, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
Line 6:        <remove name="host" />
Line 7:        <remove name="pages" />


Source File: F:\projects\dev\Orchard\test\src\Orchard.Azure\Orchard.Azure.Web\modules\orchard.setup\web.config    Line:

 

Coordinator
Oct 10, 2012 at 2:17 AM

Looks like your Orchard.Web directory is not set-up to be an application. You probably deployed the full source, or something to that effect.

Oct 10, 2012 at 2:43 AM

In my case Orchard.Azure.Web and I don't perform any deployment. Open Orchard.Azure.sln  and run debug. I'm compare current version of azure project (Orchard.Azure.Web and Orchard.Azure.CloudService) with version 1.5.1 and don't see any changes that can produce this error (version 1.5.1 working).  

Coordinator
Oct 10, 2012 at 2:51 AM

Please file a bug then.

Oct 10, 2012 at 3:02 AM

see issue number: 19116

My opinion it's critical for 1.6 release 

Oct 13, 2012 at 10:28 AM

Issue resolved by working item 19119

10x