Dashboard link for Installed themes

Topics: Customizing Orchard, Writing themes
Oct 1, 2012 at 9:36 PM

Guys, I am absolutely new to Orchard. I really want to give it a go and understand that Orchard has yet some growing to do. My first problem is this. I install a new theme and when I click on the Dashboard link, it does not work. It seems to disable the Dashboard link. I tried to install another theme and still not working. Can anyone help please? Many thanks. Andrei

Oct 2, 2012 at 1:25 AM

How does it "not work"? Are you getting an exception? Does it fail silently? What happens?

Oct 2, 2012 at 8:48 AM

Hi bertrandleroy,

Thanks for your reply. Basically, it says that it could not find the page that I was looking for. I looked under the hood, found the ActionLink for it. Seems to be pointing to the right place. The issue is though that when I go to localhost:8569/Admin it does not take me to the Dashboard. I have installed the Terra theme. Maybe I need to change the ActionLink code? I am new to MVC as well, but watching loads of PluralSight videos so, I am liking it.If need be, I will post a video of my screen which will make it clearer.

Many thanks,


Oct 3, 2012 at 12:10 AM

What happens if you navigate to /admin?

Oct 3, 2012 at 4:01 PM
Hi, when I click Dashboard, the page just refreshes and does nothing, but stays on the same page.

When I click /admin I get a "page not found" message.

When I look inside I see this: @Html.ActionLink("Dashboard", "Index", new { Area = "Dashboard", Controller = "Admin" })

It seems that the Router does not know this route?

Many thanks.

Sent from my HTC

Oct 3, 2012 at 4:22 PM

Did you try removing that theme?

Oct 4, 2012 at 4:20 PM
I uninstalled all the themes and left just the original one. And the original did not work. Created a new site and left it with the default theme which seems to be working. I will install a theme now and let you know. A bit frustrating though :)

Oct 18, 2012 at 6:06 PM

hi again,

sorry for not getting back in a while. I have managed to get it working again. I did not do anything differently. The only thing i did was to "Enable" the theme. Last time I only set it as current but did not enable it. I think that may have been the issue. Many thanks for your help.