Body part save/sent via email doesn't save in rule

Topics: Customizing Orchard
Sep 16, 2012 at 10:12 PM


Using 1.5.1;

I am making a custom form with a rule for sending an email.  If I create a couple of fields and embed the field values in the email text the values in the fields show up fine in the email.  They are saved as content items and I can query, etc.

If I add a body part to the form type, then two things happen when I put data into the body via the form/rule combination:

No information from the body is saved.

No information from the body can be found to be embedded in an email.

If I access the form directly as a content item and add data that way, the data I enter into the body part is retained.

Is this a bug or expected behavior?

Sep 17, 2012 at 12:46 AM

Sounds like a bug. Please file it. Workaround could be to use a text field.

Sep 17, 2012 at 5:17 PM

I filed the bug here:

I tried using a text field as an alternative.  Main problem I have with a text field is that the input field size by default is very small.  Where would I look to

increase the size for a reasonable amount of text?  Height x Width would be best.  thanks

Sep 17, 2012 at 5:23 PM

You can configure the size of the text field in the content type editor. You can even make it rich text!

Sep 18, 2012 at 3:27 PM

Thank you - the text field works well.   As a note to someone who might read later:   You can change the configuration of the text field by editing the

content type.  To the left of the field name is a carat (>).  Click on it and a detail menu will appear beneath the field name where you can specify the

size of the text field.