Email issues on 1.5.1

Topics: General, Troubleshooting
Aug 13, 2012 at 4:08 AM

I am having some issues configuring email on 1.5.1.  I recently upgraded from 1.4.x (can't remember exact version).  I have deleted both Orchard.Email and Orchard.Messaging modules and reinstalled.  Triple checked my smtp server settings.  Tried both from dev machine and staging (production) environment.  Below is what is in my logs..  same error in dev and production.  Anything else I can try?

 

 

   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at Orchard.Email.Services.EmailMessagingChannel.SendMessage(MessageContext context) in c:\Src\Anscott\Git\ABCPermits\src\Orchard.Web\Modules\Orchard.Email\Services\EmailMessagingChannel.cs:line 59
2012-08-12 22:03:06,043 [6] Orchard.Email.Services.EmailMessagingChannel - An unexpected error while sending a message to blahblah@blah.com: ORCHARD_USERS_VALIDATION
System.Net.Mail.SmtpException: Failure sending mail. ---> System.IO.IOException: Unable to read data from the transport connection: net_io_connectionclosed.
   at System.Net.Mail.SmtpReplyReaderFactory.ProcessRead(Byte[] buffer, Int32 offset, Int32 read, Boolean readLine)
   at System.Net.Mail.SmtpReplyReaderFactory.ReadLines(SmtpReplyReader caller, Boolean oneLine)
   at System.Net.Mail.SmtpReplyReaderFactory.ReadLine(SmtpReplyReader caller)
   at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint servicePoint)
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   --- End of inner exception stack trace ---
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at Orchard.Email.Services.EmailMessagingChannel.SendMessage(MessageContext context)

 

Aug 13, 2012 at 4:32 AM
Edited Aug 13, 2012 at 4:38 AM

so it seems that port 465 was not working for me for either gmail or rackspace smtp servers.  When I changed to 587 both work fine.  What is interesting is that 465 works great for my local email client app...