This project is read-only.

Intellisense not working in Orchard 1.5.1 and VS10

Topics: Installing Orchard, Troubleshooting, Writing themes
Aug 6, 2012 at 11:51 PM

Have been trying this for hours now, including reading through all of this: None of it worked for me.

Running on W7x64, VS10, Orchard 1.5.1 and MVC3.

It seems to me that all the fixes confirmed in that forum-thread have already been applied to the latest release of Orchard, so I reckon things should be working by now.

What I do to proof that it's not working for me, is basically just opening the Layout.cshtml of the TheThemeMachine-theme - lots of read lines in there.

Would greatly appreciate any support!

Aug 8, 2012 at 4:05 PM

Are you using the full source? Is it a clean Orchard installation? Could you show us a sample of the red lines? E.g. specific error.

Aug 8, 2012 at 4:06 PM

And are you using ReSharper? If so, perhaps try and delete the _Resharper files and folders, and try again.

Aug 8, 2012 at 6:05 PM
Edited Aug 8, 2012 at 6:05 PM

Thanks for replying!

I'm not using ReSharper and I'm not using the full source. I just downloaded the standard web-version, but it is a clean install. I tried installing it over and over again, without success. If I open the "Layout.cshtml"-file, as mentioned above, I will get red lines underneath these words:

HasText, SetMeta, Style, Script, WorkContext, Tag, Display and some more...

The error would be the typical "does not exist in the current context".

Thanks for helping me out!

Aug 8, 2012 at 6:31 PM

No problem :) Could you try with the full source version?

Aug 8, 2012 at 7:04 PM

Unfortunately, it's not working in the full source version either.

Aug 8, 2012 at 7:15 PM

You might try to close VS, then delete the .suo files in the same folder as the .sln of your solution. Then open VS again.

Aug 8, 2012 at 7:34 PM

Did not help :) Could it be something to my installation of VS, rather than the project itself?

Aug 8, 2012 at 9:24 PM

It must be something on your machine, yes, as it works right out of the box on my machines. Ignoring the red lines, are you able to compile the source code version solution?

Aug 8, 2012 at 9:29 PM
Edited Aug 8, 2012 at 9:32 PM

Can you reproduce it when you open another solution? (re-download it again?)
Do you perhaps have a beta of MVC installed? I think you have an assembly mismatch somewhere. You might want to check where your assemblies comming from. Run your solution, attach the debugger to your WebDev.Webserver, then Debug -> Windows -> Modules. Look if there are modules loaded from an SDK folder or something, which should not be the case.

Edit: as Sipke said: it should work out of the box