A 'script' named 'ContentPicker' could not be found. Error with new navigation system.

Topics: Installing Orchard, Troubleshooting
Jul 19, 2012 at 9:17 AM

Thanks for the update to 1.5, the speed of development with Orchard is amazing.

I've upgraded my local version to test any issues before upgrading our live site and I think I found an issue with the new navigation system.

I performed the upgraded exactly as the instructions (copied over the media, theme, modules and app data).

Everything seemed to work fine (though I had to reinstalled the dot.less module).

I tried adding a new side menu.

Navigation -> Add new menu -> Set name -> Save

I then tried to add new content item, (the top option on the right of the screen) and got a yellow screen of death.

A 'script' named 'ContentPicker' could not be found.

With some weird calls to

C:\Users\sebros\My Projects\Clay\src\ClaySharp\ClayBehaviorCollection.cs:29

I've tried this with a clean install and it works without issue, so I'm assuming it's something to do with the upgrade process.

Any ideas?

Jul 19, 2012 at 1:02 PM

Enable 'Ochard.ContentPicker'

Jul 19, 2012 at 2:03 PM

There's already an bug report for this problem.

Jul 20, 2012 at 7:54 AM

Yeah enabling the orchard.ContentPicker module solved it.  I searched the entire project for the issue but didn't realise it doesn't show issues/bugs in it's search results.


Jul 20, 2012 at 9:43 AM

Just for the record, it's this workitem. It's a manual step during upgrade.