Getting YSOD like request isn't getting directed to controllers

Topics: Core, Customizing Orchard, General, Installing Orchard
Jul 18, 2012 at 4:20 PM


1. Download source

2. Open, run, debug, enable custom module, debug some more

3. I will work for half a day, then hit F5 and debug again, but this time the page will show "server error in '/'" page. 

4. I build, hit Shift+F5, same result.

5. I inevitably have to unzip the source and copy over all my modules and start again...until the error happens again.


What am I doing to get this error like 5x per day, thus having to go through this tedious process over and over again?


Thank you. 

Jul 18, 2012 at 7:29 PM

Are you using VS built in server, IIS, WebMatrix (and/or IISExpress)?

I see this in WebMatrix from time to time after making code changes and restarting the application clears it right up.

Jul 18, 2012 at 7:44 PM

@reverand : I am using VS2012, and I develop using IIS Express. When this problem crops up I can make code changes, I change the port that IIS Express uses, make a new virtual directory on that new port, and even switch to cassini (buit in server) and the same problem occurs. Sometimes it will happen after running the site just two times. This occasionally happens on my hosted site and I have to have them restart IIS. However, when I restart IIS Express locally I still get the error after restart.

Jul 23, 2012 at 11:27 AM

Can you please share more details, such as what you see in app_data\logs at times corresponding to those errors?