404 after Upgrade to 1.4.2 from 1.3.0.0

Topics: Installing Orchard, Troubleshooting
May 30, 2012 at 7:56 AM
Edited May 30, 2012 at 7:57 AM

Same problems as reported in thread re: 404 after Upgrade to 1.4.1

may need more clarification on permissions for app pool user ... but directories have same permissions as with other orchard sites on this server ( not multi-tenant )

Isn't there some way to upgrade using Web Platform Installer to get bare-bones site deployed to IIS 7.5 ... then  copy files from legacy version to that upgrded directory installed via WPI ???

OP stepped thru instructions at http://docs.orchardproject.net/Documentation/Upgrading-a-site-to-a-new-version-of-Orchard as have I ...

Will go check logs ... but could there side effects due to my migration from 1.3.0.0 to 1.4.2

Happy to schedule an IRC conversation.

Thanks,

Steve

Coordinator
May 30, 2012 at 8:35 AM

Are you able to go to /admin?

May 30, 2012 at 10:18 AM

no ...

https://skydrive.live.com/redir.aspx?cid=382082018e3a07db&page=self&resid=382082018E3A07DB!131&parid=382082018E3A07DB!125&authkey=!Agkf17kXBzcOpUA&Bpub=SDX.SkyDrive&Bsrc=Share

above is link to deployed app and error file

thanks,

Steve

 

 

May 30, 2012 at 1:53 PM

Maybe you had the same problem as i had: http://schouten-online.nl/orchard-cms-error-loading-extension

Coordinator
May 30, 2012 at 7:09 PM

From what the logs are saying, the tenant can't even start. Seems to be caused by a version mismatch of sorts.

May 30, 2012 at 7:12 PM

yes ... much hacking to get to admin .... but I find a mess when I get there .... cold this be an issue with using the Mango theme ???

but, seriously ... the upgrade roadmap ... why so many problems after I follow the step-by-step according to documentation ??

Are new instructions or tools for doing upgrade in the works ???

Thanks,

Steve

 

 

May 30, 2012 at 7:18 PM

how might that happen ???  Version Mismatch ???   I am migrating from 1.3 to 1.4.2

I did go with Znowman's fix and that got me past the errors posted on skydrive ....

Will try the step-by-step again ... but please advise on revised roadmap for doing upgrade ..... has team been looking into these issues before my incident report ???

 

/s

Coordinator
May 30, 2012 at 7:21 PM

Modules. We can't know what modules you have installed. Some of them may be the wrong version, or may be incompatible with 1.4.

May 31, 2012 at 2:02 PM

Are you sure you copied all your custom modules to the new source modules folder and skipped copying all files which already exists in the new 1.4.2 modules folder? Maybe you copied everything the other way around or something or not overwritten the files with the older ones. I've had done 4 Orchard site upgrades from 1.3 to 1.4.2 but had only minor problems.

Jun 2, 2012 at 5:59 AM

Bertrand ... thank you for the admin tip ... there really needs to be documentation for simple ( I'm using Web Matrix ) conversions ...

  • Clear ponters to go to admin and perform 1.4.2 upgrade process ...
    and yes to get to be able to even get to admin ... needed to add code to the pagelist module ...per znowman ...

not n production yet .. but visible .... all links working ...

 

Thanks

Steve

Coordinator
Jun 2, 2012 at 6:21 AM

We have instructions on the upgrade process to 1.4 in the release notes: http://docs.orchardproject.net/Documentation/Orchard-1-4-Release-Notes#Howtoupgradefromapreviousversion

The documentation, like all of Orchard, is open source and accepts contributions.