Projector Suffix behaviour

Topics: General, Troubleshooting
May 27, 2012 at 6:51 AM

when using the 'Pager' and applying the 'Suffix' according to the decription (see below)

""Optional. Provide a suffix to use when multiple pagers are displayed on the same page, e.g.,  when using multiple Projection Widgets, or to define alternates.""

I still cannot use the pager i.e.: whenever I press Older the Widget becomes empty although I have total 15 elements with 'Items to Display' =10!
I tried all kind of variations with my 3 widgets but cannot figure out the behaviour!

I even started to use the Suffix and added it to my Title like 'Europe.eur' ; 'eur' being my Suffix!

? Do I need to use this Suffix somehow/somewhere ?

PS: where would I change Older/Newer to Next/Previous!?!?

Thanks for any idea on how to tackle this ?!, ed

Jun 5, 2012 at 11:25 AM

I have exactly the same problem with my projection pager. It neither works with pager suffix or no suffix. Can't get passed to 2 pages. First 2 pages works correctly but the others fail and stay empty

Coordinator
Jun 5, 2012 at 9:57 PM

Is there an open bug for that ?

Jun 6, 2012 at 7:53 AM

Well I'm not sure if edikaufmann have the same problem as but my problem/bug is already filed: http://orchard.codeplex.com/workitem/18689

Jun 6, 2012 at 8:01 AM

Sebastien, thanks for your time

my issue with the 'Pager' / Suffix' I describe in my first message above. Also I opened once a thread where you gave me th hint to use the 'Suffix'; which I did but I still having problems or miss something in this context!

PS: right now I'm on the road and have only limited access to the system! so, be patient in case you ask for additional info.

Thanks again for any hints, ed

 

Aug 7, 2012 at 11:20 PM

I am also experiencing what seems to be the same issue. I only have a single projection widget on the page with a display limit of 5 on a query of currently 18 items. Clicking "Older" modifies the URL to include ?page=2, but no items are displayed. There is, however a "Newer" and an "Older" link available to click. I can continue to click "Older" two more times to get to ?page=4 which should display 3 items out the full 18, so it is recognizing the count but no items other than the first 5 are displayed.

Coordinator
Aug 9, 2012 at 6:23 AM

What version is this?

Aug 9, 2012 at 2:33 PM

This is on 1.5.1. I deliberately waited for the new version to test again. I seem to have the same issue as with 1.4.2
My setup:
- 3 different 'projection widgets' on page (Triple first ... third)
- when leaving 'Items to Display' at '0' for ALL three widgets ->all works fine (which is in fact fine with me see www.asgbarbaroux.org  'Parcours'.

the issue:
- as soon as I set  'Items to Display' only  in Triple First' to e.g '10':
-- I'm able to use Newer/Older no problem
-- the other two 'projection widgets' work fine as well

- when setting 'Triple second' to  'Items to Display' to e.g '10'
-- I still can use Triple First correctly (i.e 10 items displayed)
-- However, on Triple Second when clicking Older Triple Second becomes empty i.e. the remaining items are NOT shown (NEWER brings the first 10 items back)

- The same happens with  the Projection widget in Triple Third.
Yes I use three different suffixes!

PS: how could I change OLDER/NEWER to Next/Back; also: do I need to change the .po file for any french translation!?
sorry for adding this very last part
and thanks for your time and advise, ed

 

 

Aug 10, 2012 at 12:43 AM
bertrandleroy wrote:

What version is this?


Mine is also running 1.5.1

Coordinator
Aug 10, 2012 at 4:15 AM

Did you configure your projection widgets to use different paging prefixes?