Cannot Install Orchard 1.4 on Azure

Topics: Installing Orchard, Troubleshooting
Mar 16, 2012 at 9:49 PM


I'm try to install Orchard 1.4 with Source on Azure, using the ClicktoBuildAzurePackage.cmd. The Build is sucessfull and i did configure the ServiceConfiguration File.

After i deployed and try to access the site i get always following error:


Server Error in '/' Application.

The resource cannot be found.


If i try to run it in the local Emulator i get the same error.

I don't know what i do wrong. Any help is great



Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /

Mar 17, 2012 at 8:57 PM

Existing site or new one?

Mar 18, 2012 at 9:55 AM


its a new Site with a empty DB and just the orginal 1.4 sources, i did try as well the Azure Package.  no luck.

Mar 18, 2012 at 4:29 PM

It's fixed.

Need to delete the Azure Storage an recreate... after its works.

Apr 12, 2012 at 12:37 AM

Could you please tell me what you meant by "delete and recreate azure storage"?. Delete storage account? I am facing the same error.

Jun 5, 2012 at 10:59 PM

The "delete and recreate azure storage" means deleting the blob's and tables as well as tables under sql azure.

check this discussion for details:

or my page for list of delete and other options: