Use 1.x or 1.3?

Topics: General
Feb 21, 2012 at 9:00 PM

Tomorrow I'll start using Orchard at work 'for real' and I'm wondering if I should use 1.3.10 as a base or use the '1.x' trunk.

Any others working on a project based on the 1.x trunk?


I heard v1.x is 'coming very soon' so I think that I should base of the 1.x trunk and switch to the final release once it is out, but I'm not sure...

Feb 21, 2012 at 9:35 PM
Edited Feb 21, 2012 at 9:37 PM

If your project timeline is longer than a month I'd recommend going with 1.x, since the timeline for 1.4 (which is based on 1.x) is around the end of this month. That way you won't have to deal with migrating from 1.3 to 1.4 while also having to worry about coding your project.  As long as you are OK with dealing with minor bugs it should be fine. If you do get bugs report them here so that the issue(s) get attention and are hopefully fixed for everyone. 

The community here is very responsive. If you uncover issues with 1.x i'm sure people will put a decent effort int making sure it gets fixed for 1.4. 

Feb 21, 2012 at 9:38 PM

1.x it'll be then. Thanks!

Coordinator
Feb 21, 2012 at 10:21 PM

By the way any bug on 1.x will be taken very seriously and very quickly.