This project is read-only.

Access to: App_Data\Dependencies\dependencies.xml' is denied.

Topics: Installing Orchard, Troubleshooting
Dec 8, 2011 at 2:23 PM


I have tried to install orchard on my host - but I can´t figure out the problem with the app_data folder and dependencies.... have no right to write to folder? And on my host I can´t change any permission....  any idéas?

Dec 8, 2011 at 2:52 PM

You'll have to talk to your host and see if they can change the permissions.

Dec 13, 2011 at 12:03 PM


They will not change any settings individually... But I don´t have to change permission for writing and updating xml-files in the app_data folder in my ordinary web-forms app.... ?

Dec 13, 2011 at 5:11 PM

That doesn't make sense. Are you getting that error all the time or some of the time?

Dec 13, 2011 at 8:32 PM

All the time... and Matrix can´t upload file as well in app_data if I try to use the publish method there. So I have to use my ftp-program to upload files.

I realy would like to get it to work and also get some advice to publish a orchard easy!

Dec 13, 2011 at 9:03 PM

There is no reason why on the exact same folder, webforms could do something that Orchard can't. Are you 100% sure of that?

Dec 14, 2011 at 2:05 PM

Yes..... I´m sure.... will ask the host... it seems to work in app_data but not in de subdirectiries... *puh*

Dec 15, 2011 at 11:46 AM

Here is the answer from my host:

"Okay, well, so here it is. The function, or rather, the CMS system you wish to use requires thatlocal webserver user Network Services has write access to specific mapar but when you are ona shared hosting server so that users have the safety devices spectra obtained nerprioriteraderights.
So therefore you can not use it to write to the folder you want.
To get around this you can use something called impersenation.
It was exactly as I wrote in my previous answer, that is.
So there you have to do is to modify how the system works for you then be able to use it with us."

And the previous answer:

"case you experience any problems with uploading files in your CMS or other code, this tends tousually be because the file trying to be written by NETWORK_SERVICE, this is not possible,then NETWORK_SERVICE only have read rights. Fix the code so it prints via the user who isimpersonatet this would solve the problem."


.. but the problem is to write to the child/subfolder to app_data...... 

Please - any advices what to do? W

Dec 15, 2011 at 6:18 PM

Well, apart from advising you to switch to a hosting company where people can actually type properly... ;)

If they want you to impersonate, then impersonate. I think they are a little confused, but whatchagonnado? What hosting company is that, if that's not indiscreet?

Dec 15, 2011 at 8:12 PM

hehe actally i copy and paste the swedish text in google translate :) (

And how do I do that? 

i have tried to <identity impersonate="true" /> in the system.web section 


Dec 15, 2011 at 9:14 PM

Yeah, that's how. You should ask your hosting company what user they want you to impersonate. I always use network_user so I'm not quite sure how to configure it.

Dec 15, 2011 at 11:08 PM
Edited Dec 18, 2011 at 7:39 PM

Hm... have send an mail to my host.. but it seems to be set default in machine.config ?

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineOnly' beyond machine.config.

Source Error: 

Line 42:   </system.transactions>
Line 43:   <system.web>
Line 44: 	<identity impersonate="true"  />
Line 45:     <!--<trust level="Medium" originUrl="" />-->
Line 46:     <httpRuntime requestValidationMode="2.0" />
Dec 19, 2011 at 2:55 PM

Today I tested with script in my web-forms to create and update and xml-file in a subfolder to app_data. And it was no problem..... so Why can´t Orchard write to app_data ?

Dec 20, 2011 at 12:21 AM

I still have no idea as it works fine pretty much anywhere. Did you consider switching to another hosting company?

Dec 20, 2011 at 12:28 AM

Thanks for Your replies... - and Yes - I have just tried to connect to another hosting company which works fine... so now I can start try it out :) 

Thanks again!!! 

.... but I´m still confusing why? The WebMatrix ftp could't upload to the app_data either.

Dec 20, 2011 at 12:32 AM

I'm afraid your old hosting company only can know. Their permissions were obviously set horribly wrong. Good thing you ran away from them.

May 22, 2013 at 2:41 PM
Hey i have found one issue go to dependencies folder , right click and propities and security tab select the network user and give him all rights