This project is read-only.

Can't sign in

Topics: Installing Orchard
Oct 27, 2011 at 9:36 PM
Edited Oct 27, 2011 at 10:26 PM

I've installed Orchard at and evrything worked great. I decided to start over so that I could install it into the root directory and now I can't sign into Orchard. When I try I use the admin user and the same password I always use. I get thrown right back to the home screen where I need to attempt the sign in again. I've wiped the system and reinstalled Orchard three times from the management app and it's the same result each time.

Also no activity in the log directory except for 1 zero length file.



Oct 28, 2011 at 1:03 AM

Is it the Orchard log in screen that you're seeing?

Oct 28, 2011 at 1:07 AM

Yes. log in fails with no info and home screen is shown again where I select the 'Sign In' link and try again.

A log file is created in the /App_Data/Logs dir but its zero length.


Oct 28, 2011 at 1:11 AM
Edited Oct 28, 2011 at 1:11 AM

This is inconsistant. I just tried it again for the 5th try and this time it says 'Access Denied'. I'm absoluetly sure I have the correct user name and password. Maybe something is getting corrupted when its stored in the db.

Oct 28, 2011 at 1:13 AM

Yeah, I'd backup the database and start over. Do you have important contents there that you need to keep?

Oct 28, 2011 at 1:26 AM

This is a brand new install that I just can't get working in the root dir at DiscountASP.Net. It works if its created in a sub dir such as the default /Orchard. I've blown away this installation 5 times think I didn't update to Orchard 1.3 correctly. not sure how to debug this. I talked to DiscountASP but there are no errors being generated and no errors in the Orchard log files so I'm at a loss.

Oct 28, 2011 at 1:35 AM

Yes, that's why I'm suggesting that you wipe it out altogether and start over. Is that a possibility?

Oct 28, 2011 at 1:43 AM

I tried clicking on the link in the mnain page "remove it by going into editing mode".  That takes me to a log in  screen and shows 'Access Denied' at the top. Any further attempts result in the same 'Access Denied'.  If I go back to the home screen and click on the 'Sign In' link at the bottom I'm taken to the log in screen. After putting the credentials I'm thrown back to the home screen with no feedback. This is consistant behaviour.

Oct 28, 2011 at 1:53 AM

OK, if you really don't want to start from scratch, you can always try this:

Oct 28, 2011 at 2:10 AM
Edited Oct 28, 2011 at 2:11 AM

I suspected that wouldn't help because I've done 5 installtions today all with the same user and password. I also used 5 different database prefixes. SSH1 to SSH5.  I made the changes you suggested to all these databases just in case but the login just throws me back to the Home screen. I get no 'Access denied' indicator.

Oct 28, 2011 at 2:14 AM

But did you zap the database between those installs?

Oct 28, 2011 at 2:18 AM

No it's a shared database with another CMS so I can't just nuke it. The unique table prefix works fine and always has. Here's the tables for users that I have now:






I've made the suggesrted edit in all these tables just in case but I'm sure my current installation is the SSH5 one.

Oct 28, 2011 at 2:55 AM

Hey Bertrand,

Any other suggestions before I nuke this installation and try this with the Orchard version that installs. I think it's 1.1.?

I'm fairly sure that that version works fine from the root dir.

Oct 28, 2011 at 3:24 AM

OK I just let DiscountASP.Net install the 6th kick at this cat. I saved an old version of Orchard.Framework.dll and it was version  Now the version is 1.3.0  so it appears they upgraded their version of Orchard some time today. OK that's all good because now I don't need to spend 40 minutes uploading the latest version via FTP on my slow connection.

Woo Hoo. Everything works as expected right away. I log in and change the template, etc. All is good.

Now I'm starting to doubt how I upgraded from 1.1 to 1.3

Here's what I did:

1. Stop web server at DiscountASP.Net and also recycle app pool just in case.

2. Using the latest version of FileZilla I copy all files in the to the root dir at my web site.

3. Start the web server and try to log into the web site.

4. Boom. no worky.


I guess the other possibility is that FileZilla isn't transferring all the files correctly or they are getting corrupted on the way up but I doubt this. there are some failed transfers but I just re queue them and they eventually go. I can't even recreate all the issues I've seen today because of the upgraded version of Orchard that is now at

I guess I should be happy that it's all working but this sure makes me uncomfortable thinking about applying a backup or a future upgrade.

Any ideas?



Oct 28, 2011 at 3:44 AM
Edited Oct 28, 2011 at 1:54 PM

I just logged out and tried to log in again was having the same issue as before and was ready to tear my hair out when I noticed something that explains all these issues. When I set up Orchard at DiscountASP.Net It gave me a link that points to the company web site as follows:   Evertything works great as long as I access the site from this URL (no www)

I have a A record at my domain registrar that points to the the IP number of my server at DiscountASP.Net.  I also have a C record there that points to my A record. The C record is

So as long as I access my site and try to log in from I'm good. If I go to I'm back to all my problems signing in.

Can anyone explain this?

May 9, 2013 at 7:12 PM
Edited May 9, 2013 at 7:24 PM
cloud - none...