v1.3 is out

Topics: Announcements
Oct 4, 2011 at 8:46 AM

thanks ,guys

Oct 4, 2011 at 3:49 PM

Awesome! But i have a problem! After i updated the Orchard on my Host, i get a Permission error on the main page!

It looks like this: 

Zugriff verweigert (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.UnauthorizedAccessException: Zugriff verweigert (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user. 

To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


What went wrong?

Oct 4, 2011 at 4:33 PM

Looks like it may be a file system access issue?

Oct 4, 2011 at 8:03 PM

Your best bet may be to setup auditing on the Orchard directory to figure out what's being denied. Was it working in the same directory before?

Oct 4, 2011 at 8:40 PM
Edited Oct 5, 2011 at 3:31 PM

Yeah it worked like a charm before... I updated the folder permissions, but it didn't help..

Anyway, if i find a solution i'll post it



// Edit

I could fix it... it seemed to be a a missing permission, but i actually don't understand why it didn't work right after the update.

Oct 6, 2011 at 9:42 PM

Just wanted to make sure this was correct....I'm using source code enlistment and updated to the latest default branch. Orchard Admin now shows my version as, however, the dashboard tells me the latest version is 1.3.9. Am I actually on the latest stable release or did I miss a step? Thanks.

Oct 6, 2011 at 9:49 PM

The build number (the third number) has never been shown in the dashboard. You are fine.

Oct 7, 2011 at 3:01 PM

Can you point me to a description of what's new in v1.3 ??

Oct 7, 2011 at 4:00 PM

@pbassey: http://weblogs.asp.net/bleroy/archive/2011/10/04/so-what-s-new-in-orchard-1-3.aspx