Placement infor file not fired

Topics: Customizing Orchard, Writing themes
Oct 2, 2011 at 6:10 PM

Hi,

I have placement file root of my them folder. But its not fire when page load. Why placement infor not fire. Do i want insert to anywhere with compile tag?

 

lakmal

 

Coordinator
Oct 2, 2011 at 10:37 PM

I don't know. Maybe you made an error in there. Hard to say with that little information. Did you try shape tracing?

Oct 3, 2011 at 4:25 AM

<Placement>
 <Match ContentType="Product">
 	<Match DisplayType="Detail">
       <Place Fields_Contrib_Image="Content:after"/>
       <Place Fields_Common_Text="Content:after"/> 
       <Place Fields_Contrib_Hyperlink="Content:after"/>
       <Place Fields_Contrib_Html="Content:after"/>
       <Place Fields_Contrib_TaxonomyField="Content:after"/>
 
       <!-- raise up specifc types Content:1.6.3 -->
      
       <Place Fields_Contrib_Html-Description="Content:1.1"/>
 <Place Fields_Contrib_Image-MainImage="Content:1.2"/>
       <Place Fields_Contrib_Html-TipIntro="Content:1.3"/>
       <Place Fields_Common_Text-Tip1="Content:1.3.1"/> 
       <Place Fields_Common_Text-Tip2="Content:1.3.2"/> 
       <Place Fields_Common_Text-Tip3="Content:1.3.3"/> 
       <Place Fields_Common_Text-PopShopParameters="Content:1.4"/> 
       <Place Parts_Tags_ShowTags="Content:1.5"/> 

	 </Match>
    <Match DisplayType="Summary">
      <Place Fields_Contrib_Image-MainImage="Nowhere"/>
      <Place Fields_Contrib_Html-Description="Nowhere"/>
      <Place Fields_Contrib_Html-TipIntro="Nowhere"/>
      <Place Fields_Common_Text-Tip1="Nowhere"/>
      <Place Fields_Common_Text-Tip2="Nowhere"/>
      <Place Fields_Common_Text-Tip3="Nowhere"/>
      <Place Fields_Common_Text-PopShopParameters="Nowhere"/>      
      <Place Parts_Tags_ShowTags="Nowhere"/>         
       <Place Fields_Contrib_Hyperlink-Reference1="Nowhere"/>
       <Place Fields_Contrib_Hyperlink-Reference2="Nowhere"/>
       <Place Fields_Contrib_Hyperlink-Reference3="Nowhere"/> 
       <Place Fields_Contrib_TaxonomyField-ProductType="Nowhere" />
       <Place Fields_Contrib_Html-RecentSearchTerms="Nowhere"/>
    </Match>
  </Match>
</Placement>

Hi,

This is my placement.infor file

 

 
 	  <!--<Match DisplayType="Detail">-->
       
        
       
       
       
 
       <!-- raise up specifc types Content:1.6.3 -->
      
       
 
       
        
        
        
        
        
<!--

       <Place Fields_Reference1="Content:1.6.1" />
       <Place Fields_Contrib_Hyperlink-Reference2="Content:1.6.2" />
       <Place Fields_Contrib_Hyperlink-Reference3="-" /> 
       <Place Fields_Contrib_TaxonomyField-ProductType="Content:1.7" /> 
       <Place Fields_Contrib_Html-RecentSearchTerms="Content:1.8" /> 
       <Place Parts_Reviews="Content:2.1" /> 
-->

	<!-- </Match> -->
    
      
      
      
      
      
      
            
               
       
       
        
       
       
    
  

Coordinator
Oct 3, 2011 at 5:21 AM

Well, if you named it placement.infor, that would explain it: it's placement.info, without a r.

Oct 3, 2011 at 5:00 PM

Hi,

 

Sorry its  Placement.info

Problem is them dont pick my Placement.info file. I have update it like this

 

<Placement>
            
      
       <Place Fields_Contrib_Html-Description="Content:1.1"/>
 	<Place Fields_Contrib_Image-MainImage="Content:1.3"/>
       <Place Fields_Contrib_Html-TipIntro="Content:1.3"/>
       <Place Fields_Common_Text-Tip1="Content:1.3.1"/> 
       <Place Fields_Common_Text-Tip2="Content:1.3.2"/> 
       <Place Fields_Common_Text-Tip3="Content:1.3.3"/> 
       <Place Fields_Common_Text-PopShopParameters="Content:1.4"/> 
       <Place Parts_Tags_ShowTags="Content:1.5"/> 


      
</Placement>

Now there is no match. All the filed template is inside filed directory

 

Coordinator
Oct 5, 2011 at 8:24 PM

What do you see in shape tracing?