This project is read-only.

Deployment with vs and or ClickToBuild.cmd?

Topics: General, Troubleshooting
Sep 13, 2011 at 2:25 PM

Hi i'm trying to publish my website but i find my self having some problems. When i use the ClickToBuild.cmd, i miss the sites folder from AppData. I'm also getting 3 different built folders:

  • buildtasks
  • build
  • artifacts

Which folder do i have to publish? and is it possible to deploy this code directly with webdeploy without creating a new VS solution and open the built files before i can deploy? I don't think the documention is suffucient enough for this part.

When i don't use ClickToBuild.cmd and use VS to publish the website with the source of Orchard opened the published code is way to big in size because of the duplicated dll's.

Can someone give me advice on this one?

Sep 13, 2011 at 3:33 PM

You can use clicktobuild to create a deployable package. Use the content of the zip file from artifacts\msdeploy, or you can also use directly the one in \build which is uncompressed. They are the same. Those ones contain no App_data, they are just code builds.

You can also publish using Web Deploy under VS.NET, but you need to be in Release mode, then the whole deployment will be only 35mb. And the App_data will also be synchronized.

Ultimately you can use Webmatrix, which also can deploy website, and even synchronize your local copy and your deployed one.

Sep 13, 2011 at 3:48 PM

You said: "You can also publish using Web Deploy under VS.NET, but you need to be in Release mode, then the whole deployment will be only 35mb. And the App_data will also be synchronized."

You mean open the \build directory with Visual Studio and publish from there? Or do you mean the full source and set is to release mode and publish without the clicktobuild?

or how can i published the generated zip to the server?

Nov 16, 2011 at 7:25 PM

Because my deployed website is still to/quiet big (around 180mb) and the performance is lacking on our live server i'm starting to think this has something todo with the way i deployed the website.

is it possible that orchard detects to often changes en recompiles every time there's a request? and is it possible this has something to do with my deployment?

I deployed using web deploy. Normally webdeploy only deployes the files which are included in the visual studio solution but now with Orchard it deploys everything so also the files which are not included in the solution. Is this normal behavior?

Nov 16, 2011 at 11:03 PM

No, webdeploy should only deploy what's necessary. Are you sure you didn't change its configuration and told it to deploy everything? In any case, manually building is the sure way to do it.

This being said I doubt it has anything to do with the problems you're seeing. Did you check the parameters for recycling the app domain? might be the memory limit that is set too low.

Nov 17, 2011 at 9:21 AM

unfortunately is also deploys files like svn folder,etc. In my package/publish web setting is "Only files needed to run this application" is selected and applied. Is it possible that's this is not working correctly because of the included solution folders like "Modules" and "Themes" ?

Nov 17, 2011 at 6:34 PM

You should probably use the command-line to build then.

Jan 5, 2014 at 9:58 AM
Today I tried to create a package using ClickToBuild.cmd and found that the compilation fails:
"G:\Orchard.Source\Orchard.proj" (Target Build) (1) ->
(Target Test) ->
    G:\Orchard.Source\Orchard.proj (145,5): error MSB6006: Completion of "unit-console.exe" code -532462766.
Branch 1.x

Jan 6, 2014 at 1:40 AM
Why are you using ClickToBuild and not build Precompiled?
Jan 6, 2014 at 10:50 AM
Hi, Bertrand

I need to put together a package (1.x) with a minimum amount of disk space for hosting testing. In this sense, tool ClickToBuild.cmd, what my need. But it does not work. Free testing for hosting, I can not use more than 1000 MB of disk space.
Jan 7, 2014 at 3:11 AM
Right. build Precompiled creates a built version of Orchard that is a few MB, not a GB. Not sure what gave you the impression that you had to deploy a GB.