tags do not work

Topics: Troubleshooting
Aug 29, 2011 at 5:51 AM

I do not see the Tags menu when I am writing in Blog. The tags is on, and available from left side panel, but I do not see menu to input them.


I use last stable verion of Orchard.

Aug 29, 2011 at 1:22 PM

Is that picture from the Blog itself, or from a Blog Post? The Blog itself does not have Tags associated with it by default. If it's a Blog Post, then it normally does have Tags associated with it.

So, if that's a blog post and you don't have a textbox for entering Tags, it's likely that the Tags part is not attached to the Blog Post content type. To add it, click the Content link in the dashboard menu, then click the Content Types tab at the top of that page. (If you don't see a Content Types tab, then the Content Types feature is not turned on - go to the Modules page and enable Content Types first).

When you're on the Content Types tab, edit the Blog Post content type and add the Tags part to it. Save that, and you should now have a Tags field on your blog posts.

Aug 30, 2011 at 6:18 AM

Thanks it's work!

But what Tag menu should do? I thought I can write there some predefined tags, and than simply select them in blog post drop down menu? I added few tags, but they do not shown on drop down menu.

Aug 30, 2011 at 6:28 AM

It's to manage the tags that you set up in content items.

Aug 30, 2011 at 10:25 AM

Thanks! Does it's possible to set tags with Live Writer?

Aug 30, 2011 at 12:26 PM

Yes, Live Writer allows you to enter tags on your blog posts and they will map to Orchard's tags when you publish the post.