all static files return a 500 error

Topics: Installing Orchard, Troubleshooting
Jul 14, 2011 at 10:48 AM

So my site is currently here:

http://stage.giddy.co.in/

And if you check chromes console you'll see all static files return a 500 error. For example :

http://stage.giddy.co.in/Modules/Contrib.Stars/Styles/Contrib.Stars.css

This static file works/loads http://stage.giddy.co.in/Themes/Fizz/Styles/Site.css  because, what I did was comment out this line:

 <add name="StaticFile" path="*" verb="*" modules="StaticFileModule" preCondition="integratedMode" resourceType="File" requireAccess="Read" />

Now, there are many other js/css files not returning, so its impossible for me to goto each directory and change the web config there? Or should I deleted the web.config files? Dunno if this would cause more problems?

Im on shared hosting, is there a way for my provider to flip a switch for something like this? I read somewhere that changing overrideModeDefault to Allow in the applicationHost.config would work?

Any ideas?

Thanks a ton.

Gideon

Jul 17, 2011 at 5:45 PM

Did you solve the problem?. If so, can you post the solution?

Thk

Jul 17, 2011 at 5:51 PM

no not yet, do you have the same problem?

My hosting guys said they're looking into it? Somehow I don't have this problem on my same shared hosting with orchard 1.0?

Coordinator
Jul 18, 2011 at 8:32 PM

This is extremely curious: the static files should *not* get served if you don't have that line in web.config. Can you enable custom errors and report back with a full stack trace (or look in app_data/logs for a stack trace corresponding to the error)?

Jul 18, 2011 at 8:49 PM

Solved !!!

It was an IIS7 configuration missing (Static content), so you have to go to Control Panel -> Programs and features, then to " turns windows features on or off", then in the tree view for windows features, expand Iternet Information Services -> World Wide Web Service -> Common Http Features and check Static Content.

Aug 1, 2011 at 6:44 AM

@jme do you have the line <add name="StaticFile" path="*" verb="*"....   in your web configs?

I commented that line out of about 50 files and now for some horrendous reason I get 404's from 15 random directories, some including the directory for the css files which I just changed! =S