Post installation steps failed with error: Sequence contains no matching element

Topics: General, Installing Orchard
May 5, 2011 at 9:40 PM

I am using Orchard version 1.1.30

I get the following error when trying to install the "Import Export" module using the buildin gallery:

Post installation steps failed with error: Sequence contains no matching element

Help :-)

Coordinator
May 5, 2011 at 10:20 PM

Can you give more details, such as a stack trace?

May 6, 2011 at 6:43 AM

No events is written to the windows application log. Where should I look?

Coordinator
May 6, 2011 at 7:16 AM

Try \App_Data\Logs

Coordinator
May 6, 2011 at 7:34 AM

We've seen this error recently when you enable a module after install, and the module depends on another module not installed. The "fix" is to install the dependency (you can go to the "features" screen to see what's missing).

May 6, 2011 at 4:36 PM

I have alot of empty log files in \App_Data\Logs e.g.: orchard-error-2011.05.05-04_55_00.110.log

I used sql compact, which did run really slow. Now I run the site using SQL Server Express 2008, which works much better. Now I don't have any problems installing modules. So I guess that the problem was related to some kind of timeout.

Coordinator
May 6, 2011 at 7:22 PM

The empty log files are a known issue: http://orchard.codeplex.com/workitem/17774

May 12, 2011 at 9:12 PM

I get the same issue, here's the message from the log.

2011-05-12 13:03:49,524 [21] Orchard.Recipes.Services.RecipeHarvester - Could not discover recipes because module 'Orchard.CodeGeneration' was not found.

I clicked install for the CodeGen module from the online gallery, then when it asked if I wanted to enable it, I said yes.  I got the "Post installation ... " error. When I went to Features and enabled the feature (after an iisreset) it worked.