This project is read-only.

No styles during setup and when not logged in

Topics: Installing Orchard
Apr 7, 2011 at 12:06 AM

I installed a new version of the Orchard source from the zip file according to the instructions in the documents section and using IIS 7 on my computer. During the setup when I get to the Orchard setup screen where you setup the database etc. it displays with no style sheet applied. I proceeded with the setup anyway and it is working but when I am not logged in I don't see any style sheets applied.

I assume this is a permission problem somewhere but I've been looking all over the place and I can't figure out where the issue is. If I try to just enter the path to the css file into my browser I'm redirected ot the login page.

All the web.config files seem to be the correct default ones including the one in the folder with the site.css file. I tried giving full permissions to everything to the app pool just in case that had anything to do with it but same issue. Can anyone point me to places I can try looking, I'm out of ideas right now.


Apr 7, 2011 at 12:10 AM

To be 100% sure, can you make a diff of all we.config files in the site (using windiff or a similar app)?

Apr 7, 2011 at 12:45 AM
Edited Apr 7, 2011 at 12:46 AM

Edit: Sorry missed part of your post

Apr 7, 2011 at 7:03 PM

I solved the mystery this morning. It turns out the problem was in the folder permissions but what was interesting was that a permission I added by mistake disguised the problem.

What I was missing was read permission for the 'Users' group on the Orchard.Web folder, without it IIS throws a 500 error saying 'Cannot read configuration file due to insufficient permissions'. I guess there may be a specific user for this rather than the group. What I had done instead was to give read permission to my Orchard app pool. In this case I didn't receive the error about the config file and I got the html of the page but I didn't get the script or css files. Once I signed into the site I could see everything fine.

Thanks for your help. After the diff came out the same that sent me back to looking at folder permissions.